View Full Version : No disc inserted into selected device

02.08.2008, 23:43
Hello. I am currently using Daemon Tools Pro Advanced 4.30.0302, and whenever I try to make an image of a CD it gives me an error that says "No disc inserted into selected device". Now the program shows that the drive I am trying to make an image of is the right one (I only have one physical), and when I look at the same drive in windows it sees the contents. When I look at the drive in daemon tools it shows the CD title, but under device media info it says that the disc type is empty, and file system is unknown.

Their has been a recent hardware change, which I am not sure affects the issue or not yet. My motherboard (EVGA 790i Ultra) has 6 sata ports, and technically has 2 esata. The motherboard vendor has modified one of the esata channels to fit sata, and just last week I plugged my drive into it so that I could figure out if I could toss in a 6th hard drive, and make my second raid array a raid 5. The drive used to be plugged into that the sixth sata port that is currently unused (wanted to make sure everything worked, and I could boot from the esata port before purchase). Going to try switching it back to the sata port to see if it resolves the issue, but just posting here in case this is something that needs to be fixed, or there are others who are trying to figure out what is going on. Any suggestions will be appreciated.

03.08.2008, 01:10
Switching back to the standard sata port seems to have resolved the issue. However since this prevents me from being able to install a sixth hard drive. I would still like to know if there is any other way to resolve this issue. I mean windows sees the drive, I can even use it, but I cant image it.

17.08.2009, 14:43
Switching back to the standard sata port seems to have resolved the issue. However since this prevents me from being able to install a sixth hard drive. I would still like to know if there is any other way to resolve this issue. I mean windows sees the drive, I can even use it, but I cant image it.

I am using Daemon Tools Pro Advanced version 4.35.0306.0088 and I am having the same problem: "No disc inserted into selected drive" pops up as soon as I click on the "Start" button right after initiating "Make disc image". But there IS a CD-ROM in that one-and-only physical drive, and the name of the CD shows in the Daemon Tools "Physical device info" display box, although there is no information showing up in the "Device media info" display box right under the "Physical device info" box. I have a very simple system compared to Cyong's. I'm running Windows XP Pro, SP3. The CD-ROM is a simple generic AOpen model CD-952E/AKH made in China in 2001. Windows reads it just fine while DAEMON Tools Pro runs; it shows up as CD Drive E. DAEMON Tools Pro displays it as Vendor: E-IDE, Model: CD-ROM 52X/AKH, Revision: A63. So WHY won't DAEMON Tools Pro Advanced make an image of an inserted CD-ROM data disk? I have tried going into the Windows Device Manager and uninstalling the CD-ROM, then hitting "Scan for hardware changes". Upon reinstalling the device, the problem persists. Curiously enough, the trial version of DAEMON Tools Pro Advanced reads the exact same CD just fine and makes an image of it just fine when I run it on my laptop. Someone please HELLLLLP!

17.08.2009, 16:36
If any - which other burning apps do you have installed ?
Do you use any Packet-Writing-Software (DLA, InCD, etc.) ?

18.08.2009, 05:27
Thank you for your reply. I have no other burning apps installed in this system. Whatever comes with Windows XP Pro, SP3 is probably installed, but I have never used it. No packet writing software is installed.

18.08.2009, 10:28
Would you please download the tool Filter Driver Load Order (http://www.bustrace.com/products/devfilter.htm), execute, select your CD drive
on the left and -if available- post Upper/Lower filters listed on the right.

Regardless of the forum support:
Please also contact the official support (http://www.disc-soft.com/sendmsg) with reference to this thread.

19.08.2009, 09:46
Thank you so much for your help. Here is the clipboarded output from running devfilter.exe and using my E-IDE CD-ROM 52X/AKH as the input device:

Filter Driver Load Order Professional software bus analyzers, USB, SCSI, iSCSI, SAS, ATA, ATAPI, Fibre Channel, and more! (http://www.bustrace.com)

Upper Device Filter: redbook
Device Object: E-IDE CD-ROM 52X/AKH
Lower Filter Drivers: No Lower Filter Drivers specified for this device

Driver Name: redbook.sys
File Location: c:\windows\system32\drivers
File Description: Redbook Audio Filter Driver
File Version: 5.1.2600.5512 (xpsp.080413-2108) [5.1.2600.5512]
Product Name: Microsoft® Windows® Operating System
Product Version: 5.1.2600.5512 [5.1.2600.5512]
Company Name: Microsoft Corporation

I never heard of "redbook" before. Can you enlighten me in re to?

19.08.2009, 12:02
Redbook Audio Filter Driver

kinda says what it does in the post :) its a microsoft filter, so its safe...

20.08.2009, 11:19
Hello jks049
It's hard to contact you behind that very "cool" antispam system :-)
In case you are waiting for response from support team, please make sure you will receive e-mail from us.

20.08.2009, 13:21
Oops! Sorry about that! Earthlink's spam blocker is indeed VERY good at what it does. I usually catch "allowed sender request"s quite soon after they arrive, but I have been off line for almost 2 days attending to family concerns. I'm back now, and I have called my Earthlink anti-spam dog off of DAEMON Tools Support. Thank you for your patience and for your reply.

22.08.2009, 17:20
OK, Support Teamies! I just sent you the logs.zip file that you requested I generate. 'Sorry to take so long to get this done, but work and family took priority this past week. I sure hope you can find the bug that's causing this problem. Thanks ever so much for your great customer service!

08.10.2009, 20:37
I am having the same problem. Did you find a solution?

01.05.2012, 21:59
Having same problem. It used to be ok a couple of months ago. Then it broke... I reinstalled system and still having problem. Unfortunately I didn't test DT straight after windows reinstall.

I have:
win 7 ultimate 64bit
DT lite edition.
no cd/dvd programs (but I had alcohol, clone cd, nero 9 installed for tests)
I have MS virtual PC and vmware workstation 8 (I disabled vmware but didn't help)
Filter Driver Load Order doesn't show any additional drivers

13.01.2013, 12:45
Ok, there is solution and source of my problem:
- mainboard: Gigabyte: GA-P55-UD4 with Intel 6 SATA + 2 sata JMB362 (jmicron)
- 4disc raid connected to intel + dvd LG connected to jmicron

I plugged dvd drive into intel and it begun to recognize disc. Then I plugged back to jmicron, install jmicron drivers and it works!!!
It used to be standard microsoft driver which didn't work correctly with DT (but no problems with other software).