View Full Version : I cant play purchased games

21.10.2008, 14:30
Since I installed daemontools and had it working for sometime, I noticed that any game I have purchased cant be played. Every time I try to run a game it displays the same message: Please insert the correct CD-ROM, select OK and restart application. Even though the CD is in. I've tried to fix the problem myself without any progress. What can I say? Please help, im frustrated.

21.10.2008, 15:10
Does it happens with original disc?
Have you created any image and if yes, how?
Which games exactly?
Your OS and DAEMON Tools version?

26.10.2008, 12:49
With original discs yes.
Latest game I tried was assasins creed. I have got battlefield 2 too. Neither working. The one I got interested in was this one: Hearts of Iron 2 Armageddon. See it doesnt require CD to play after installing the game. The game launches all right, unlike any other, but then it jams in loading textures for the gameplay. I was like "WHOHOOUUUuuuuuFUCKYOUU!!".
My OS: Microsoft Windows XP Media Center Edition
Aand for creating an image Im not sure. I dont really know what you mean by that? Have tried asking friends advice for that one but no luck so far. I'll try to figure that out for you.

26.10.2008, 12:54
Which DAEMON Tools version are you running? Have you also installed CloneCD?

26.10.2008, 18:20
Nope, no CloneCD. And version is Daemon tools lite 4.30.1

26.10.2008, 18:33
Try deleting the following in regedit and then try again:

If not working, does the games start when you uninstall DT Lite and SPTD (www.duplexsecure.com)?

22.11.2008, 20:48
Yess! Finally! I got it working! At least BF2 is. I uninstalled daemontools and that SPTD thingy and it totally works! Thanks a million for helping me out with this! I owe you big time, and I doubt if I'll ever be able to make it up for you. THX!!!!!

Roberto Elier
23.11.2008, 17:02
Please, somebody can help me to discover how to mount an ISO in Virtual Daemon v3.47? All what happens when I tray to paste an ISO in virtual drive es the message 'Insert a disk', or something so. TIA
Roberto Elier

23.11.2008, 17:14
ISO doesn't contain protection related data. Recreate with proper profile.
Also update to 4.30.

Also to mount just right click on tray icon, virtual cd/dvd rom, select the drive, mount image.