View Full Version : Can't play Securom 5.00.03 protected game

Irven Eran Larr
06.02.2004, 16:04

recently I got Sonic Adventure DX. It's protected with Securom 5.00.03 at least that's what Protection ID says. When I tried to play it for the first time with my original CD, it wanted me to insert the original disc although it already was inserted. I presume that it has detected my version of Daemon Tools. But: normally this shouldn't be possible because I've installed version 3.44 and renamed the bus and port drivers. Of course the game didn't work when I tried to use the image or a copy via RMPS-emulation. Does anyone have a good suggestion what I could do? Thanks for your help!

Irven Eran Larr
08.02.2004, 09:14
Well I think this is a really big joke. I own the original game and can't run it. Then a crack is published and as soon as I use it the game works. Does that mean that the gaming industry wants us to crack their games in order to be able to play them at all. *lol*
How can someone be that stupid?!
In any case the game works now just fine and everybody (in this case I) is happy about it. :D

10.02.2004, 19:55
whoo hoo hoo hoooo

calm down, pal :) even the securom guys are probably redoing some thinking... couple of game companies are doing about their stuff, at least.

You could have checked a couple of things...

DT emulation OFF - still not working?
DT drive OFF - still not working?
Since you didn't post it... if you got alcohol or clonecd's virtual drive installed, you should try the above with them, also...

BTW, i got (to my knowledge) exactly one game with this shit on it, so my contribution is not exactly of empiric value... but i ain't got a single problem with it... using DT 3.41 :) (playing from disc not image)