View Full Version : "Please insert the disk..." for all mounted images

07.11.2008, 16:08
Hello all. Just reinstalled my Windows XP SP3 OS. A couple of days I had no problems mounting all kind of images and accessing them just fine.
However I don't know why now every time I try to mount an image file and install some game or application I get the "Please insert disk number..." or "Please insert the disk...".
For example in My Computer all seems fine with the virtual drive.
I don't know what else to do. I also tried other mounting applications with no success.
I used the images that I'm trying to mount now before and everything worked fine.

Could it be because of the SATA driver for my HDD or such ? Basically the SMART failed for my HDD and when it was returned back from the warranty the HDD wasn't Hitachi anymore but Fujitsu. I am using the Windows XP SP3 install CD into which I inserted the SATA drivers with nLite when I had the Hitachi HDD. Now I have the Fujitsu HDD but the driver works fine as I can leave the SATA option activated in bios and boot Windows (I have a HP Compaq 6720s).

What else can I do to get this working again ?
Thanks in advance.

08.11.2008, 14:11
Just installed Windows Vista Business and latest version of Daemon Tools Lite. I have the same problem.
After I click the install button of every application mounted it asks me for the CD.
I'm beginning to think that this is an emulation issue.

13.11.2008, 20:19
Hmm... Your problem seems to be similar to mine (I created another topic for that: Images/Virtual Drive won't work). Is your virtual drive clearly visible?

I'm wondering what the source of the problem could be *sigh*.

14.11.2008, 15:29
daemon tools could easily run and install programs/games up until recently when i formatted my computer..now it always says insert the correct cd-rom
no matter what i'm trying to install
obviously the format changed something on here..but i don't know WHAT

please someone needs to figure this one out!

22.11.2008, 14:45
I think I've got an solution for this. Maybe it works if you set the virtual drive (instead of the physical) to be the first drive when the computer asks for a CD.

Does somebody know how to change the priority of "reading drives"? It should be somewhere in the Windows Control Panel.

22.11.2008, 15:35
Priority? I think you want to know how to change drive letters.

Control Panel -> Administrative Tools -> Computer Management -> Disk Management -> Right click on optical drive -> Change drive letters and path

22.11.2008, 16:31
Quote: "In Windows Control Panel, make the virtual drive the first drive to be read instead of the physical CD-ROM drive."

Are you sure he/she meant "changing the drive letters"?

23.11.2008, 17:36
Just signed up to complain about this issue too - it's a real pain in the butt.
I hate having to fish out my old cds - so many to search through >_<

I've been recently suffering from this issue too, and I'm pretty sure I've found the cause.
What happens (on my system, at least) is I'll mount a image, run the autorun software, and something will cause the virtual drive to eject itself. I have no clue WHAT causes it, but I've so far been unsuccessful at making it insert the virtual drive's tray back in. If I eject it myself before something else does, then I can re-insert it fine, but it'll still eject itself after I do, leaving me stuck as to what I could do.
Any ideas?

23.11.2008, 17:54
Image only gets unmounted itself when access to image file is somehow bad. E.g. through bad drivers, network, raid etc.

25.11.2008, 05:08
Image only gets unmounted itself when access to image file is somehow bad. E.g. through bad drivers, network, raid etc.

I've tried accessing the image to no avail from my iPod (acting as a external drive), my 250GB SATA and my 500GB SATA drive.
I've not tried it from my IDE drive.
There aren't any issues that I know of with my configuration - Daemon Tools is the only software that gives me issues.
Also, as I said, the image isn't unmounted, but the virtual drive acts as if it has been ejected, as if you were to eject the disc tray while installing software from a physical disc. I can't make Daemon tools re-insert the tray, but it does say the image is still mounted.

Any clue as to what COULD be going wrong?

25.11.2008, 07:29
So, I'm assuming you guys have post moderation enabled.
Anyway, can you please edit this into my other post.

I've just tried using Alcohol 120%'s virtual drive feature, and the same issue is present. Could this be a Securom Blacklisting or something? If so, is there any workaround that doesn't involve the removal of Securom?

04.06.2009, 22:05
just go in control panel then select administrative tools then select computer management then select disk management then scroll down til you find your main cd drive letter then right click it select change drive letter and path then slect change and you will get a drop down list and select a different drive letter for it then open deamon tools and right click the deamon tools icon in the bottom right corner of your screen the icon thats in your toolbar at the bottom then take your mouse up to were it says virtual cd\dvdthen another window will pop up then move mouse over it and u will see a option to set device parematers select that then you will see a box come up and you will see a place were it says drive letter click that and you will get a drop down of letters and select the letter that you origanal cd rom was then it will work fine.... remember to reverse this if you want to set the original one back....any questions email me at mblanton1974@yahoo.com

08.06.2011, 19:32
This doesnt work for me. And the image doesnt get unmounted it gets ejected.

I've tried all of my drive letters but still no succes.. :(