PDA

View Full Version : Daemon Tools hampered by 3rd party DVD driver from Sonic Solutions



MisterBlack
12.12.2008, 11:16
Hi,

For about two months Daemon Tools won't work anymore, nor do other similar programs. Whenever I tried to mount an image, Daemon Tools performed as it was actually mounting the image, but no image was present in the explorer window. I also noticed that my real DVD drive isn't available either, even though it is detected in the boot sequence.
I checked in the device manager and both the real DVD drive and the Daemon Tools created images showed an incompatibility error.
I checked further and it seems that an additional driver from Sonic Solutions popped up from I don't know where among the default Windows DVD drivers, and it's messing with everything that is DVD related.
Since I can't access my DVD I obviously can't reinstall DVD drivers from the windows xp install CD. Also, any uninstallation of the 3rd party driver form Sonic Solutions along with the other drivers, results in an automatic reinstalation of all drivers, including the 3rd party one.
Did any of you guys run into this before. Can I do something besides reinstalling Windows?

Terramex
12.12.2008, 13:16
What's the name of the very driver ?
How did you try to uninstall that driver ?
Have you also tried to completely uninstall the program the Sonic driver came with (Sonic Record Now, MyDVD, Sonic DLA, etc.) ?

MisterBlack
12.12.2008, 15:15
Thanks for the reply.

I'm running Windows XP, I've just installed SP3.
The 3rd party driver is listed in the driver details window as
Sonic Solutions and it's not digitally signed. Now, I read on some forums that this Sonic Solutions thingie might have something to do with some Roxio software, but I've never installed anything related to Roxio on my home computer. Also, I just found out that I have this driver installed on my computer at work as well, and on that one Daemon Tools seem to work just fine.
I'm rather puzzled.

Blazkowicz
12.12.2008, 15:41
Download Imgburn -> install the program -> start it -> Tools menu -> Filter Driver Load Order -> remove any filter except redbook. It is possible you have to reinstall your burning and ripping tools. So remove only step-by-step the filters.

MisterBlack
12.12.2008, 20:26
Hey Blazkowicz, thanks a million for your help, the trick worked, I have everything up and running now. Again, thanks a lot.
One more thing, could you please explain me what those filters are about, I just want to know what I am doing next time, because in this occasion I just followed your instructions monkey style. :D

Blazkowicz
12.12.2008, 20:55
Some bad filters (they get loaded for all optical drives) can cause these problems.