View Full Version : Daemon Tools Pro drive error: -1

14.12.2008, 15:41
Sorry if this was posted before, I searched but could not find the solution.

Daemon was working perfect but now it does not work. When I usually disable all drivers when closing daemon. Now I start daemon and when setting the number of drivers (usually 1), I get a message box saying:

Daemon Tools Pro driver error: -1

No matter what I try, even tried setting more than one driver but I cant seem to get rid the message. So I reinstall daemon tools lite (latest version) but no luck. :confused:


14.12.2008, 15:44
You are talking about drives and not drivers.

Also your OS and your exact DAEMON Tools version is?

14.12.2008, 18:01
The version is DAEMON Tools Lite V. 4.30.2 and its meant to be drives not drivers lol sorry. My OS is vista. Any help?

15.12.2008, 16:23
Just thought l'd let you know l am also having exactly the same problem:

OS: Vista - Service Pack 1 32-bit
Daemon Tools: 4.30.2

15.12.2008, 20:46
Found a solution, this worked for me:

1) Reboot your computer
2) Press F8 while it's starting up to bring up the boot options (with safe mode etc.).
2) Scroll down to "disable driver signature enforcement" and press enter.


16.12.2008, 12:00
Wow thanks it worked!


15.01.2009, 12:27
According to this article (How To: Disable Driver Signature Enforcement in Vista, http://www.overclock.net/windows/187919-how-disable-driver-signature-enforcement-vista.html) if you do this using F8 step, you must do that every time you boot your PC, then they suggest run the following command:

bcdedit -set loadoptions \"DDISABLE_INTEGRITY_CHECKS"

I did it, and it worked fine for me. In a similar article I saw same command, but a little bit different:

bcdedit /set loadoptions DISABLE_INTEGRITY_CHECKS

I didn't check this last one...

Well, I hope this could be helpful to everyone that experiences this issue.

03.02.2009, 09:03
how can i do this on xp sp2?

03.02.2009, 14:31
Check post #5.

04.02.2009, 14:24
I am having the same problem, after reading post 5 i tried his method but when pressing F8 i get no disable driver signature enforcement option.

I am running windows xp service pack 3.

04.02.2009, 20:06
Open boot.ini in c:\ and add the following at the end of your Windows "/EXECUTE"

It should look like this:

[operating systems]
multi(0)disk(0)rdisk(2)partition(2)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT /EXECUTE /USEPMTIMER

Ensure there is no /NOEXECUTE in this file.

21.02.2009, 01:08
I get the same error message when trying to set the # of drives except I get an error: -2 instead of -1. Is there a difference? I'm running XP.

24.03.2009, 12:41
Hi, first post on here,
Having same problem but.. my boot.ini has this:

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

It has no execute, but I'm still getting the error..
What needs to be done?


24.03.2009, 17:32
The instructions* seemed to say that you need to delete the "/NOEXECUTE" paramater and replace it with "/EXECUTE"

* From previous posting by Blazkowicz

Open boot.ini in c:\ and add the following at the end of your Windows "/EXECUTE"

It should look like this:

[operating systems]
multi(0)disk(0)rdisk(2)partition(2)\WINDOWS="Micro soft Windows XP Professional" /FASTDETECT /EXECUTE /USEPMTIMER

Ensure there is no /NOEXECUTE in this file.

23.04.2009, 09:35
Blazkowicz said

Open boot.ini in c:\ and add the following at the end of your Windows "/EXECUTE"

It should look like this:

[operating systems]
multi(0)disk(0)rdisk(2)partition(2)\WINDOWS="Micro soft Windows XP Professional" /FASTDETECT /EXECUTE /USEPMTIMER

Ensure there is no /NOEXECUTE in this file.
I tried it but it doesnt work. Should I reboot it????:confused:
MY OS is XP sp2. And my boot.ini file looks like this

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Please Explain in detail what to change! Thanks in advance!:)

25.04.2009, 20:58
[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

You need to read the directions a little closer. You should change the above to the following:

[boot loader]
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /execute /fastdetect

26.04.2009, 18:22
Sorry it doesnt work! so i use alcohol 120! Still prefer daemon though!:mad:

27.04.2009, 00:39
think that setting is for dep isn't it? and i dont think its the reason here, cos i have dep on on one of my pc's, and off on the other and have never had a dt pro problem when installing

27.04.2009, 01:54
Yeah, that changes DEP settings to disabled. I don't know if it fixes anything or not, I was just helping mura figure out what to do. I never turn off DEP on any of my machines and have never had an issue with Alcohol or DTools Pro.

27.04.2009, 11:56
same here, i think the problem has to be something else :(

27.04.2009, 18:20
Well, I never turned off Daemon... I only used to unmount the images.. I use only Daemon lite 4.30.. Just i question.. What is dep????:confused: Alcohol 120 works well so far:)

28.04.2009, 08:18
dep = data execution prevention

put simply, before its existance, code could be executed from the stack and/or memory areas... now, those areas have to be marked as 'executable' for the system to allow it to run, if dep is enabled and a program tries to execute from the stack or from a memory area that is not marked as executable, it generally results in a crash / error appearing and the program being terminated

some old protections did this, running code from the stack (safedisc and securom in particular), which is why in windows xp sp2 and higher, there is a 'handler' for this in the pe loader which enables dep for those executables...

Data Execution Prevention - Wikipedia, the free encyclopedia (http://en.wikipedia.org/wiki/Data_Execution_Prevention)

14.07.2009, 05:07
check out this guy's post Its all too Geeky...: Daemon tool pro error : -1 (http://thegeekway.blogspot.com/2009/07/daemon-tool-pro-error-1.html)

04.10.2009, 15:03
2 of my friends had the same error message directly after installing Daemon tools and fixed it by uninstalling and reinstalling.

07.08.2010, 22:47
I got second newest daemon version, (lite) and I have XP sp3.
Somehow similar problem, but it asks tells me about Daemon tool pro drive error: 3.
I google'd the problem and found other topic, but it didnt help me out at all.. :frown:
Heres the picture bout error screen (its Finnish, I translated it.).
I have battled with this for some time, and havent beaten it yet.
Help would be appreaciated.
(I didnt bother to make new thread).

08.09.2010, 20:09
This is what The GeekWay (now relocated) advised:

Rightclick My Computer
Select Properties
Select the Hardware tab
Click on Device Manager
Look for SCSI and RAID controllers - It will already be expanded and there will be a cross on its icon (not visible in image) which indicates that its not functioning.
Right Click on ANNxxxxx IDE controller and select Update Driver
Update using default options.

With me, it was not exactly like this, but it pointed me into the right direction:

while still having the error, SCSI and RAID controllers contained one driver only already marked by xp with a yellow exclamation mark. Update requests could not solve this (driver not found), but assuming it was a remaining thing of the defective DT Lite, I completely removed it. Then, uninstalling and reinstalling DT Lite inserted an operational controller there. The installation took quite some time "updating the drivers".

Interestingly, the new controller is a different one (different name, at least) from the one I had before.

Having XP64 SP2


10.12.2010, 13:54
i had the same problem, and it worked! now i just have a new problem:
Daemon tools pro driver error: 3

anybody who can help?

09.02.2011, 15:35
Hey guys,
I'm having about the same problem...
first time I started Daemon Tools for Windows 7 (Latest version) it said I didn't have a virtual drive... it gives me an error message saying: Pro Driver Fout: 3
I don't get any of this and I don't know how to make it all work, cause I really want it to work fast! :P

Please help me! :D


28.02.2011, 23:34
Hi, I dont know if posting this here is not right but I have a question I have the daemon tools lite version 4.40.2 with WIndows XP Pro w/Service Pack 3. I tried to turn it on today and it gave me that error also when I installed like two days ago every time I tried to start it up it said updating virtual devices and every time it did that it asked for a reboot and never started. If I can get some help with that it will be greatly appreciated, Thanks a lot.

21.08.2011, 09:17
try installing 3.47 if u use xp, much better and stable than the others on xp :) and uses little memory

20.02.2012, 00:00

I have DT Pro Advanced Edition 4.41.0315.0262 installed and getting the "pro drive error -1" message when I try to add a virtual IDE drive. I dont get it when I try to add a DT virtual drive. I tried the driver signature enforcement solution and re-installing solution but they didnt work. Any other suggestions?

20.02.2012, 09:31
Download the latest SPTD driver from DuplexSecure - Downloads (http://www.duplexsecure.com/en/downloads).
Run SPTD setup and click "Update", then reboot your system.
After reboot run SPTD setup again to check if the driver is successfully installed (you will see text like "same sptd version was detected").
Then start DTPro and check the problem.

21.02.2012, 12:40
Tried it. Didnt work. Getting the same problem. :\

21.02.2012, 14:18
Please try this Microsoft FixIt solution: Your CD or DVD drive can't read or write media (http://support.microsoft.com/mats/cd_dvd_drive_problems/en-us)

21.02.2012, 17:20
Isnt that for physical optical drives though?

By the way I noticed in my device manager that under storage controllers, "AV8JE3YQ IDE controller" is marked with an exclamation mark with the devices status as "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

Is that related to this problem? I googled the controller and it came up with no results :\

21.02.2012, 18:31
Isnt that for physical optical drives though?It's for virtual ones as well - or more precisely Windows handles both types the same way.
For example have a look here: http://forum.daemon-tools.cc/f19/storprop-dll-redbook-sys-29162/
Most likely also a filter conflict on your system.

22.02.2012, 21:38
Which option do I select at the question "Are you trying to play or burn a disc"? "Play" or "Burn"?

I clicked on - "Detect problems and apply the fixes for me", then "BD-Rom Drive(h:)" to get there.

24.02.2012, 07:56
The "Play" option.

28.02.2012, 18:31

I selected the play option.

Then I selected the Insert a supported disc option after mounting the .mdx file that I need to use. Then it did its thing and took me to a window that says troubleshooting is complete. But the message on the window says that - "we detected some problems with your system and were able to successfully apply the fixes. However our verification shows that the problem sitll exists". I tried adding the virtual IDE drive and it didnt work so the message was correct.
I have attached the result report to this message for your consideration.

Cheers! :)

29.02.2012, 14:25
Please uninstall DT Pro & SPTD (the latter with the standalone installer from Duplex Secure).

Then remove possibly existing filter drivers with ImgBurn as described here:
No virtual drive in My Computer | DAEMON Pro Help (http://daemonpro-help.com/en/problems_and_solutions/no_virtual_drive_in_my_computer.html)

Reboot and install latest DT Pro Version 5.0.0316.

P.S.: if you don't want to use any Mountspace feature disable/uncheck both options in Preferences/Media info

24.11.2015, 08:54
Whats OS and exact DAEMON Tools version
Thanks , ??