View Full Version : Hard drive dissapears after installing daemon tools

23.02.2004, 17:46
Operating System: Win XP pro - sp1
Burning Software: nero express, burnatonce
Anti-virus Software: symantec antivirus corporate edition
DAEMON Tools Version: 3.44

I have 3 harddrives, C,D,E. They are all seperate hardrives, C is a SATA drive, the other two are IDE drives connected as a master and a slave on the primary IDE channel.

After I install daemon tools v3.44 on my computer and reboot, the D: Drive (Master IDE) is no longer visible in windows explorer or in the device manager. But if I go to the "add hardware wizard" and scan for any changes, windows will recognize the drive.

If i uninstall Daemon tools, everything works fine again and the drive is automatically detected. Anyone know a solution or a fix for this problem, that would let me keep daemon tools installed?

24.02.2004, 08:03
Very strange problem, as Daemon should not affect detection of other devices. Do you use special drivers on you main IDE channel?
If you use Intel Application Accelerator try to remove it.

27.02.2004, 00:34
No, I dont use any special drivers or anything, and I dont have the Intel Application Accelerator.

I did try going to the device manager and under "IDE ATA/ATAPI controllers", I removed "Primary Ide Channel". I then restarted and let windows redetect it and both drives were recognized. However on the next reboot I had the same problem again, only the D: drive wasn't automatically recognized.

Edit: heres some other system info, in case it might help.

-Gigabyte 8knxp motherboard with version F8 bios.
-I have one western digital raptor harddrive connected via SATA as my C: drive
-two hard drives as a master and a slave on the primary IDE channel
-a cdrom and a dvd rom drive on the secondary IDE channel.

If you need to know anything else, let me know.

27.02.2004, 10:51
Have you forced Daemon drive letter to some value above E : ?
And what happens if you reboot with all virtual drives disabled?

27.02.2004, 22:35
The first time I install daemon tools, i restarted right away after installing it, and the virtual drive appeared as drive D: and my hardrive would not show up.

So I uninstalled Daemon Tools, and reinstalled again. Only this time I didn't restart when the install program told me to and I first created a virtual drive, it showed up as the H: drive. Thinking the problem was solved, I restarted only to have the virtual drive still show up as the H: drive, but my D: drive (the harddrive) still did not show up.

Also, I tried disabling all the drives like you suggested, and the D: drive was still not detected.

27.02.2004, 22:41
Honestly i cannot understand why only your master is not detected and why only with Daemon. Mystique. As if some PnP conflict.
We'll try to investigate this issue.
Does it happens too if you disable virtual SCSI controller and reboot?
(you will get the invalid device messages).