View Full Version : Virtual Drive Cannot Be Deleted

15.04.2009, 00:31
I installed Daemon Tools Lite on my Windows Vista Ultimate. I mounted many images successfully, but the last one failed. I could not even open it. I uninstalled DTs as suggested and I now have 2 virtual drives that cannot be removed. I even tried reinstalling and the "ghosts" are still there. I have spent hours on the net looking for a issue specific to mine to no avail. Could anyone out there please advise me as to what to do. This is becoming extremely frustrating. I have read on various forums situations close to mine and none of them work in my particular case. I have even removed these drives using my Device Manager and after reboot, they reappear. Please help me shake this thing. BTW - I am not comfortable editing the registry. Anyone have any software they would recommend to help?



16.04.2009, 07:05
Have you tried to reinstall then set the number of virtual devices to 0 ?


Edit: added picture

16.04.2009, 07:30
Thanks for the idea, but where in Daemon Tools LITE are you able to set that?



16.04.2009, 07:55
Hi again, Underheaven:

I did try what you suggested just now... You cannot set to 0 drives, you can just disable all virtual drives. Guess what? The phantoms have returned. This is getting really frustrating and there doesn't seem to be an answer out there. I have read thousands of posts complaining of the same thing and it doesn't seem anyone has solved it. What's up with these daemon tools? Could you recommend a forum where the content isn't monitored? I can't wait days for a reply that may or may not work. I am truly fed up! Too bad, the folks from daemon tools won't pipe in. Not to offend, but you (guys from DTs) know of this issue and have done nothing to solve it.... If this doesn't get posted, atleast I got to vent. Next step is to reformat my entire computer. What a shame that something as simple as downloading a trial tool can cause so much aggravation.


16.04.2009, 10:58
Un-install Daemon Tools, remove SPTD layer (start with point 2! No safe mode required.):
Then re-install. Ensure you reboot before reinstallation!

16.04.2009, 14:29
By the way the forums aren't censored or anything. They are just moderated as an anti-spam measure (for users under 20 posts only).

17.04.2009, 06:12

Thanks for the input... Sorry to be so negative, but here I go again...


I have tried everything you have suggested to the "T". IT SIMPLY DOES NOT HELP!!! I appreciate you trying to help, but your advice does not pan out. I have read numerous posts by you in search of a solution and they are so ambiguous... Why be so cryptic with your responses? I am not even sure you read my issue as your solution had nothing to do with my particular case. I have tried disabling daemon within my registry and I have used the device manager in the attempt to remove the "ghost drives" - they keep coming back everytime. I am not alone. I can point to countless other posts on other forums where people have NEVER found a solution. When will DT's own up to this and offer a real solution. After this experience I will never purchase from DT, EVER... They have been accused of spreading MALWARE. They must be awfully DAMN good, because I have heard of instances where SpyBot was unaffective. This is ridiculous... I am going to simply reformat my computer and be done with this SH*T... This is truly unbelievable....


17.04.2009, 13:16
Which DT version have you used ?
Would you please attach/upload an image of your Device Manager showing the 2 drives and your SCSI controller(s) ?

They have been accused of spreading MALWARE. They must be awfully DAMN good, because I have heard of instances where SpyBot was unaffective.Everything was tranparent about the Adware DT lite once used and it could be easily removed via Add/Remove programs. Just do a forum search for Adware+Uninstall.

17.04.2009, 15:09


17.04.2009, 16:13
Those drives are quite obviously not Daemon Tools related.
And please show a pic with your Storage controllers section visible, not Network adapters. ;)

19.04.2009, 15:46
Thanks, Copytrooper. What are they then? They weren't there before installing DT's. In fact, they are the same drives to which DT's mounted my .cue image files. And they are empty drives. Here are the storage controllers:


BTW - I installed Daemon Tools Lite 4.30.3 three times now. I would really like to buy the pro version since it is able to burn just about anything, but I am reluctant with the problems I am having.

Thanks again,


19.04.2009, 17:05
What I can see is ...
1. No Daemon Tools controller in storage controller section,
2. no Daemon Tools devices in DVD/CD-ROM devices section (DT Lite devices are SCSI, not USB).

Google came up with this:
Motorola Q-Phone and Active Sync - XP Hardware (http://forums.techarena.in/xp-hardware/908051.htm)
Did you have some similar device connected?

21.04.2009, 22:24
Thanks, Copytrooper...

It seems to be a Dell drive issue. I apologize for me assumption...:confused: