PDA

View Full Version : Detecting correct LaserLock version



Popup-Box
26.04.2009, 23:35
Which copy protection identifier application is the most precise one (pertaining to detecting the given version of the copy protection, if possible)? I'm struggling with a laserlock protection at the moment, but I presume I have not tried all the available settings combinations when creating/burning image (yes, I try mounting virtual drives first, then burning to a cd-rw just to check - so far everything has resulted in "Insert correct CD").

I've downloaded programs such as BlindRead/Write, Alcohol 120%, and CloneCD in addition to Daemon Tools. Several got suggestions for configurations associated with laserlock protection. I've tested all I've come across. After some experimenting lately, I think the best approach is to find the most recommended copy protection identifier program and hope it detects the laserlock version. Then I may at least exclude a few of the suggested settings the varying programs provide, if there is a discrepancy between different versions of the laserlock protection (which it obviously is, as I have not succeeded using a few of the suggested laserlock settings already).

Concerning protection detection: I've tried Protection ID, CD Info and several others, no information on the laserlock version as far as I remember. Which of the existing such programs is most accurate? Alternatively, any other ideas on how to solve this problem?

evlncrn8
27.04.2009, 14:25
protectionid should report the laserlok version if you scan the exe / installation folder... i actually clean forgot about puting it in the cd/dvd sector scan because i didn't have any laserlok disks... i'll try and find some

if protectionid does not detect the version, can you please upload the exe somewhere and send me the link and i'll take a look

Popup-Box
27.04.2009, 19:43
There is an excess of available tools in Protection ID, but all are not relevant to the problem. After scanning the entire CD, the Protection Report window shows nothing. Log Window is full, obviously. The comment attributed to the main executable (CM2.exe (it's from Championship Manager 2 96/97)) is "File is NON MZ/PE executable..skipped". Similar descriptions seem to be common, .exe or not. The comment for INSTALL.exe is "File does not appear to be PE executable". Note that the installation works, it's the running of the program that results in an error message. There are five files in the LASERLOK folder on the CD: laserlok.in, laserlok.O10, laserlok.O11, laserlok.O50 and laserlok.O52. The first three laserlok files are commented thusly: "File is a NON executable..(non MZ)", while the last two got: "File Read Error.. skipped". Also, the scanning of the last two took 8.5 and 7.8 seconds. The first three laserlok files took 2 seconds or less each to scan.

I'm still unable to find anything about the laserlock version by using Protection ID, but the application is definitely helpful.

A.Hecka
27.04.2009, 21:06
Try also another optical device to create the image.

What is the name of the title you want to image?

evlncrn8
28.04.2009, 01:24
try scanning the installation folder, not the cd..
i plan to update the code in pid as/when/if i get a game with laserlok, or find a mini/maxi image somewhere to work from...

Popup-Box
28.04.2009, 02:44
A.Hecka: As in creating the iso with another cd drive/burner? I doubt that's the issue, because even when using the original cd I have experienced the "Insert correct cd" problem. It seems to be a very strict protection.

Name of the title? The label? Simply "CM2", if that's what you mean. I've tried that to, in order for the image to correspond to the original as much as possible.

evlncrn8: I think I scanned the installation folder too earlier, but I just did it again. Many of the same files are present, with the same comments in Protection ID. The laserlok files were not inclded, however, if I read correctly while browsing through the scan log. (Just a thought: the cd is from around 1995-96. It's mysterious if there is no way around this one, as I understand there have been solutions for varying laserlock protections.)

I've prepared uploading the main file, cm2.exe (both from the original and from an attempted copy on a cd-rw just in case there's a difference, which I doubt). Where should I upload?

evlncrn8
28.04.2009, 07:23
upload to megashare etc, whatever is easiest for you, and big thanks :) im still hunting for some laserlok mini images, and will update protectionid with detecting laserlok on cd/dvd too as/when i have something to work from.. we plan a new release soon (within this week if all goes well)

Popup-Box
28.04.2009, 11:56
The file is 1.06 MB.

CM2.exe from the original cd: Link 1 (http://www.megaupload.com/?d=RXD2XQFP)
From the cd-rw copy: Link 2 (http://rapidshare.com/files/226682293/CM2cdrw.EXE.html)

You probably don't need the cd-rw version (it's very likely identical), but I included it just in case.

evlncrn8
28.04.2009, 15:24
thanks, both files were identical...

and surprisingly its a 16 bit executable.. you might have problems running this in vista or higher, which explains why protection id wouldn't 'see' it (pid only processes 32 bit files..)

can't really help you 'remove' the protection either, its been a long long time since i debugged 16 bit versions of any protection..

Popup-Box
28.04.2009, 17:40
Yes, I run it through DOS in Virtual PC. Does not work in XP. Even DosBox is not able to run it.

I guess I'll keep on searching and see if anyone else reads this and got knowledge on it.

pseudo555
01.05.2009, 19:02
Maybe you can try with older protection identifier (like clony xxl - i'm not sure clonyxxl can help)...

evlncrn8
01.05.2009, 19:42
for 16 bit, i really doubt it will

Popup-Box
01.05.2009, 21:53
I've got ClonyXL Final, and I scanned the CD in question with all protection identifiers available to me a few days ago. I'm quite certain that I would have noticed it and remembered if Clony XL Final actually did recognize the specific version of the protection. As far as I remember it didn't. I did scan the virtual drive on which I mounted an image of the CD now - Clony suggested it was an audio CD (there are sound files on it, which obviously confused Clony). I'll scan the actual CD with Clony again soon just to be sure.

Popup-Box
02.05.2009, 14:32
ClonyX Final detected, among other things, the following about the CD:

Tracks: 1
Data tracks: 1
Audio tracks: 0
CD Name: CM2
CD serial: BBECCE92
Total: 649 MB

Dummy Files: no
Overburn: no
TOC: ok
Track length: ok

Copy-protection or CD typ: LaserLok

The "LaserLok" is clickable, and it provides a suggestion for settings associated with CloneCD. I may try once more to create an image with CloneCD and burn it on the cd-rw, although I am also quite sure I tried a week ago without success. I can't recall exactly whether I used the settings that ClonyX suggested. However, if I did not, I still guess that the settings suggested by ClonyX correspond to a great extent, maybe completely, with the settings suggested by other identifier applications that suggested settings for LaserLok protected CDs.

Popup-Box
04.10.2009, 17:14
Anyone with suggestions now?

It appears that the CD is in a dubious condition, which isn't surprising considering it was bought in 1996, and there are visible hints of its age. That said, I'll test the CD on another computer in order to verify that it is getting worse.

gf7
09.10.2009, 23:39
Scan the CD with BurnOut.
It should tell you the Laserlockversion.

evlncrn8
10.10.2009, 11:09
and burnout reads 16 bit executables now? ;p

gf7
10.10.2009, 11:24
yes, it does :cool:

Popup-Box
17.10.2009, 01:25
BurnOut detected "LaserLock", no mention of any particular version, however.

evlncrn8
17.10.2009, 14:40
yes, it does :cool:

actually thats kinda incorrect isn't it.. it looks for MZ, then scans for a string, there's no executable processing per-se, which is what i meant in my question

Popup-Box
17.10.2009, 14:51
Scan the CD with BurnOut.
It should tell you the Laserlockversion.

BurnOut is able to detect what is described as "LaserLock" and "LaserLock Marathon" if I remember correctly what the protections.txt suggested. It did detect "LaserLock", but does it imply any specific version, however?

Another question: Is there a LaserLock version which people never have been able to work around that you know (that is, one from the 1990s, given my CD was released in 96-97)?

evlncrn8
19.10.2009, 14:48
well 32 bit laserlok is relatively simple to crack, however such discussions are frowned upon on the forum, 16 bit is a bit trickier, but its essentially the same check, where it looks for the developers name in the laserlok.in file, and does other small checks, it should be emulatable with daemon tools, but because its 16 bit, you might have problems running it on xp etc.. it definately will not work on an x64 based system, the version number also isn't always stored in the exe (if anywhere), so tracking the exact version might be a bit tricky

gf7
20.10.2009, 18:48
@evlncrn8: Right, but it works as you can see. But shouldn't we stay on topic?

evlncrn8
21.10.2009, 16:20
i am, but i wanted the question answered properly, and with my other posts i did stay on topic and 'it works, as you can see' isn't exactly accurate either, i can make a text file which will be reported as laserlok too, which is why i asked you about processing 16 bit exe's

Popup-Box
21.10.2009, 16:59
it should be emulatable with daemon tools, but because its 16 bit, you might have problems running it on xp etc.. it definately will not work on an x64 based system, the version number also isn't always stored in the exe (if anywhere), so tracking the exact version might be a bit tricky

Interesting clarifications, but I run it (the original) in a simulated DOS environment using Virtual PC anyway, so the XP, x64, x32 etc. issue is not a problem. The core seems to be that this particular kind of laserlock is an excessively tricky one to get around.

evlncrn8
21.10.2009, 17:45
so, making the image and 'forwarding' the daemon tools drive in virtualpc etc doesn't work? does it see anything in the drive, or does it give a 'put original disk in drive' style error?

Popup-Box
21.10.2009, 19:24
so, making the image and 'forwarding' the daemon tools drive in virtualpc etc doesn't work? does it see anything in the drive, or does it give a 'put original disk in drive' style error?

It's about half a year since I actually attempted to solve the problem, so I may have forgotten a few details. However, I tried both to burn the image on an empty CD as well as mounting the image as a virtual drive. The content is detected, I was able to browse the files, categories of the copy, but not to run the program properly. As far as I remember, I focused more on burning it to the empty CD than mounting virtual representations, so there might be the potentiality that I did not try a particular solution (a specific type of burning setting associated with a specific image creator) re the mount method, but should it matter? I tried e.g. Clony, DaemonTools etc., ridiculously many, since different programs provide for varying burning/image settings. Hence, my idea is to find out precisely what type of laserlock I'm struggling with.