PDA

View Full Version : Help needed with IMG file



sparkle_guy
08.06.2009, 13:05
Please excuse me if this isnt exactly the right place but I am new to working with IMG files.

I have an IMG file which I have mounted on a virtual drive using Daemon tools. It is my understanding that an IMG file is an exact copy of what would be on a disc which would start when put in the hard drive. How do I make an IMG file mounted on a virtual drive "run"?

When I click the drive to see whats on it all I get is a standard windows warning that "the disc may be corrupted or that windows does not support the disc or the drive needs to be formatted". How do I make the IMG run as if the real disc had been put in the PC. Of course the IMG file could really be corrupt I guess but as I've never done this before I'm a bit lost. Thanks in advance for any help

Copytrooper
08.06.2009, 14:57
Such problem is usually caused either by damaged image file, or interfering/missing drivers.
Check in device manager if any drivers are installed for the virtual devices. There should be cdrom.sys, storprop.dll and redbook.sys.
If no drivers are installed, click on install drivers and point to cdrom.inf supplied by OS (in hidden Windows\Inf folder).
If all mentioned drivers are installed, but also some additional filter drivers check this thread, too:
My real cdrom/dvdrom drives are missing - THE DAEMON TOOLS FORUM
Also check if you've a file infcache.1 in Windows\Inf folder, (re-)move it, then try again.
Sometimes also some antivirus or similar software prevents correct image file access, try to update/disable such software.

sparkle_guy
11.06.2009, 21:20
Hi Copytrooper thanks for your reply

This is driving me nuts.

I have tried a number of IMG files with no luck so I don't think the IMG file is corrupt.

I ran the automatic Micro soft fix in the KB article and it was instaled when i tried to run it again I got a message that said i didn't need to run it.

Made a new virtual drive and monted the IMG file sill no luck same eror message.

Tried to reninstall the CD driver from CDinfo as suggested. You can not point to the file you can only point to the fle that contains it. Did this and checked the drivers installed and found the installed ones are as follows
C:\system32\DRIVERS\cdrom.sys

I don't see the other drivers mentioned any idea how to install them if they are necessary.

I found the INFOCACHE file and logged on as administrator but could not delete or move it kept getting the message permission required to carry out ths action. As admin treied changing the permisions on the files security tab seemed to work but I still got the same mesage I cannot move or delete it. I tried renaming it but same error message.

So bottom line I've done my damdest and mounted the IMG file but when I clcik the drive I still can't get it to run and when I look at the properties of the disc it has nothing showing.

Any further help or sugestions would be really great.

Thanks in advance Sparkle Guy