View Full Version : Won't boot 'cause of SPDT.sys, but SPDT.sys doesn't exist

25.07.2009, 19:55
So the other day I turned off daemon tools for the first time since I installed it a few months back. Didn't think anything of it, then yesterday a replacement cd drive came in for the laptop (HP DV8315nr - AMD Turion 64). I hit the power button and swapped the drives out, turned it back on and the cd drive still wasn't working. I then realized I just put it in hibernate and didn't fully shut it down. So I hit the restart....Nows when it gets bad. I get the typical freeze at loading SPTD.sys and system reboots. Doesn't matter what I do I can't get past it.
To compound things, for some reason the laptop will only stay on for maybe a minute to troubleshoot, as if it is overheating. If I lay it on ac vent while I am working I am able to get several more minutes out of it. This has never happened before this.
So since I don't have a working cd drive or a floppy, I was able to make a usb flash drive that boots into the windows recovery console. I navigate to the windows/system32/drivers folder, but no SPTD.sys exists! same for dtscsi.sys.
So I have nothing to delete, but I still have the error.

I am locked out good. I think I can get another laptop that I can add this hard drive to, would it give me any more options?

Thanks for any help!


27.07.2009, 00:19
I think I got the overheating problem fixed. The heat exchanger fins were packed with dust.

Still no boot though. Anybody? I ordered an adapter so I can put the HD in my PC. If I have to do a restore at least I can save some stuff.

27.07.2009, 00:46
Boot with your Windows cd into recovery console, log on to your Windows installation (requires Administrator password), and enter disable sptd (this will disable SPTD service). Reboot to check if your issue is solved.

27.07.2009, 03:29
when i do that it says something to the effect of this process doesn't exist.

28.07.2009, 04:30
I picked up a 2.5" to 3.5" IDE adapter so I could work on the hard drive in the PC. In windows I couldn't see anything, it said the drive was corrupt.
I had an Ultimate boot cd (highly recommended), started it and was able to view the drives. I went into the drivers folder and their was the SPTD.sys. got rid of that, problem solved. Don't know why I couldn't see it from the recovery console though.