PDA

View Full Version : Error message "No language support detected"



sniper58
17.12.2002, 23:08
Hello, I am running XP and version 3.26 Daemon Tools is installed. For this error message to disappear I have to uninstall, then reinstall Daemon Tools, which is annoying to say the least. I am running Evidence Eliminator and suspect this is the culprit. Anyone experiencing the same problem, either solve or confirm my suspicions. :?:

Fr3dY
10.02.2003, 11:46
It happens the same to me, under Windows 98SE. I never had problems with Daemon Tools, but now I'm not able to open it, receiving the same error message. The mounted images are still there.
Maybe it's caused by using Registry Healer, I don't know yet. I opened 'Regional Settings' under Control Panel and it's fucked! The available list of countries/languages has repeated and invalid entries. Anybody know what's up ? Thanks

Fr3dY
10.02.2003, 12:13
I used the program API MONITOR to trace the calls from Daemon Tools 3.29, and saved the logfile. You can see it as plain text or load under API MONITOR (recommended). I think you'll be able to know what's up after seeing this log.
My log is available at http://fr3dy.meanmachine.ch/daemon.zip
Api Monitor is available at http://www.rohitab.com/apimonitor/

Please take it a look and tell us what happens. Thanks

Development
10.02.2003, 12:46
This happened because your registry cleaner destroyed some important registry settings of Windows Installer that are used by Daemon Tools.

sniper58
10.02.2003, 13:16
I also run registry healer, so this is the common link, it has to be the culprit, thanks for your reply and goodluck.

Fr3dY
10.02.2003, 13:20
I made it work again without reinstalling Windows.
Here are the steps I followed:

Download Windows Installer 2.0 (MsiInstA.exe)
Decompress the file to a chosen directory by using 'msiinsta.exe /c' from command line
Execute MsiInst.msi from that directory
Remove Daemon Tools
Remove units from Hardware Manager (Virtual CD Drives and Virtual SCSI hosts)
Reinstalled Daemon Tools
Everything working fine now

Hope it works for you too. Bye!

Development
10.02.2003, 21:59
Normally it should be enough to uninstall and install again Daemon Tools only.

Fr3dY
10.02.2003, 22:06
No, it didn't worked for me just removing and reinstalling it.
I received either the 'language support' message error or some kind of internal error after installing Daemon Tools again.

Development
11.02.2003, 17:50
Ok, thanks.