View Full Version : Not a valid win32 application?

19.08.2009, 02:02
I downloaded DAEMON tools lite v4.30.4 from: Disk-Tools.com - Published Software Download (http://www.disk-tools.com/download/daemon)

But when it try to run the application it says: deamon4304-lite.exe is not a valid Win32 application.

Could someone please tell me what's going on and how to fix this? :confused:

19.08.2009, 07:38
Redownload setup please.

24.09.2009, 13:52
I've tried downloading several times, but always get the message "Not a win32 application"

Do you have an alternative download format - e.g. Zip instead of exe.

24.09.2009, 17:08
Check hash sum (CRC, MD5, or SHA-1) of 'daemon4304-lite.exe' file.
If file is correct, corresponding value should be:


24.09.2009, 18:08
I have the same problem too. Just installed and updated a fresh install of Vista 64.

24.09.2009, 19:11
jiandrews, read my post above. Or you have another DT version?

30.09.2009, 20:03
Wrong file size. When downloading daemon4304-lite.exe it says 7.3MB and downloads a full 7.3MB. When I look at the file that is left on my desktop it's only 473kb.

I am not on the new Vista 64 install anymore and have switched back to a 1 year running 32bit version of Vista and I still have this problem. Even though I am a registered member of this forum, I was not allowed access to view the image you have posted above.

30.09.2009, 20:22
Try again. It may be a problem with your download manager.

30.09.2009, 23:58
I don't use a download manager. I am just clicking the download link on disc-tools.com and the windows "Save File As" box downloads to my desktop.

I have now downloaded on my XP laptop and dragged the file over the network to my Vista machine.

The problem of downloading a 7.3MB file and only getting a 473kb .exe has now occurred on both Vista 32bit and a clean install of Vista 64bit. Neither build had AV or any kind of blocking app. The 64nit was just installed, windows updated and then tried installing DT.

The vista 32 bit was happily running and installing DT 4.10

01.10.2009, 10:56
Just checked. I have no problem with downloading DTLite from Disc-Tools.com - Published Software Download (http://www.disc-tools.com).
Try to use another browser.

04.10.2009, 06:14
This just happened to me,

it is due to a corrupt download,
you must first remove the saved file you first downloaded
then just run (not save) the file on a clean re-download
and this should work fine.

Worked for me, hope it works for you


05.10.2009, 00:27
i had the same problem for awhile. try going to a different site to download it. download.com worked for me. hope this helps

05.10.2009, 11:34
Having the same problem. Tried all the suggestions in here, but no matter where I download from, or whether I run, or save file to drive before running, I still end up with the "Not a valid win32 application" popup whenever I try to launch a mounted ISO.

Uninstalled and re-downloaded about ten times now. Tried both these download links:-

Disk-Tools.com - Published Software Download (http://www.disk-tools.com/download/daemon)

Daemon Tools Lite - Free software downloads and software reviews - CNET Download.com (http://download.cnet.com/Daemon-Tools-Lite/3000-2646_4-10778842.html?tag=mncol)

The files I am getting say they are 7.3 megs.

Also, dont know if it matters but when installing, I choose to opt out of the toolbar installation.

My System:
Vista 32bit
Service pack 2
Dual core optimisation
Athlon 64 X2 Dual Core 5200+
2 gigs DDR2 800Mhz RAM
GeForce 8800 GTX 768mb
Running AvG anti-virus and adaware. Neither seem to be conflicting with daemon tools lite.

Any help or advice would be appreciated.

05.10.2009, 11:40
You have a problem with ISO, not with DT. Is it reproduced with another ISO images?

05.10.2009, 11:46
Possibly. Maybe Alcohol 120%, Though I’m not certain.

Does DT only work with ISO’s created using DT pro?

05.10.2009, 12:13
No, it doesn't.
What is this image you have mounted? How did you get it?
Try to mount any other image.

05.10.2009, 12:31
A vista32 compatible game given to me by a friend.

I’m not sure what was used to create it.

I was told to either use Alcohol or Daemon tools to mount the image. I read that Alcohol has issues under vista, so decided to give DT a go. Although the instructions my friend gave used Alcohol as an example.

No I haven’t tried mounting anything else yet.

05.10.2009, 13:11
So I cannot help you, 'cause it's not DAEMON Tools problem.
Maybe your game is compatible with Windows Vista, but not with Service Pack 2.

15.10.2009, 15:35
I turned out to be the download file size for me too.
After several retrys I never did manage to get a version that worked. A friend has since burned the ISO onto disk for me, so its not a problem.

I could suggest a possible issue with the daemon tools download server? as I have NEVER come across this issue with any other download.