View Full Version : YASU cloaking - Enter correct DVD error

30.10.2009, 04:30
Hi there!
I've recently installed Battle for Middle Earth II onto my system again via a .iso of the DVD. I have lost my copy of the actual DVD put have recovered my CD key from Electronic Arts (EA).

I mounted the image with Daemon Tools Pro and the game installed fine, however when I tried to run the game I got the error message "Please insert the correct DVD."

A friend suggested I use a crack to bypass the need for the DVD which worked but it also altered the game version which gave version mismatch errors when I tried to join an online game.

So I removed the crack and tried the YASU tool but I still, however, get the same error message, "please insert the correct DVD."

Is there something I can do about this or will I have to buy another copy of the game?

Would making a new image of the original .iso I used to install the game make any difference, by using one of the many image creator 'profiles' DTPro has?

I've also heard of programs such as A-Ray to detect the kind of protection or blacklisting a program uses... Would knowing any of this help in my situation?

Sorry for all the questions... I'm a little baffled by all this if I'm honest.

Thanks in advance for any reply :)

30.10.2009, 08:12
iso is useless for copy protected disks, it can't store the sector timing information etc..

you would need to remake the image mds/mdf format, with alcohol or daemon and then try it..

30.10.2009, 16:37
Can I make those from the .iso?

30.10.2009, 16:57
No, you can't.

30.10.2009, 18:19
Ok. Thanks for the help... Just bought another copy which was only £9.99 so it's not all bad.

30.10.2009, 20:26
well, from that one you bought (presuming it was original) :), then you should be able to make an image from it and it should hopefully work...