PDA

View Full Version : Daemon Tools Lite compatibility



LEONE KING
12.11.2009, 17:50
Daemon Tools Lite 4.30.4.0027

Is it work on final version of W7 with SPTD 1.62?

Blazkowicz
12.11.2009, 18:57
Yes, but i would already update to 4.35.

LEONE KING
12.11.2009, 22:09
New version is cool! I tried it, and I like it, but I like and an old versions. They are useful and cool too!