View Full Version : Problem with Sidebar Gadget

12.11.2009, 14:28
I'm running windows 7 and downloaded the latest daemon tools. Upon reboot I get the following error Line: 46 Error: 'null' is null or not an object daemon tools. After I hit no for debug the widget pops up.

12.11.2009, 16:08
Please describe your problem more detailed (in step-by-step format). Post screenshots.

12.11.2009, 16:53
Installed latest dameon tools for windows 7. Reboot error comes up see attachment. I also attached the debug. Select yes or no to debug. If I select no widget comes up.

13.11.2009, 11:51
Your posts were moved to new thread because your problem isn't related to Kernel Debugger.
It will be investigated.

13.11.2009, 16:46
I've sent updated gadget to you by email. Please reinstall gadget and verify if your problem is still reproduced. Inform me about the results.

15.11.2009, 04:11
That worked perfectly. Thanks!

20.11.2009, 07:14
I get the same error when I reboot and the gadget tries to start. Can I get the fixed gadget as well? If not can you tell me when it will be available to everyone?

20.11.2009, 13:18
814 - updated gadget

20.11.2009, 21:16
Thank you for posting the fix. When I click on the link it says I do not have permission.

20.11.2009, 21:47
Please try again.

20.11.2009, 22:00
That did it. Thank you very much.
It also fixed my problem. No more error message.

21.11.2009, 17:41
Hi. I have experienced the same problem in my windows vista, reported it here, I got it fixed installing this new gadget.
Why isn't this fixxed gadget added to daemon tools download yet since so many people have experienced this problem?

My post: http://forum.daemon-tools.cc/f19/daemon-gadget-runtime-error-problem-25589/

22.11.2009, 08:13
Why isn't this fixxed gadget added to daemon tools download yet since so many people have experienced this problem?

Only three people reported about problems with Sidebar Gadget. So, most likely updated gadget will be included to the next DT Lite version.

15.12.2009, 01:20
Also got the same problem. Got it fixed with the new gadget. Thank you.

29.12.2009, 17:12
I'm having the same error '46' when I try to install the sidbar gadget.

20.09.2011, 22:31
Hello. I'm having a very similar error.

Win 7 Professional
7 Sidebar v1.60
Daemon Tools Gadget v1.0.1.0 (also tried the supplied file in this thread, registers as v1.0)
DTLite v4.41.3.173

When I attempt to load the gadget that came bundled with DTLite it tries to load and disappears with no error message (this only happens after I have loaded Sidebar 7 once. If I reboot and do not run the sidebar, it loads fine). When I attempt to use the DT Gadget supplied in this thread it stays open but displays a message in the gadget's window that reads "Error: Gadget initialisation error" and will proceed no further. Doesn't bonk out and close, but doesn't function either.

Any chance at some joy from the brilliant coders of DT on this one?

21.09.2011, 09:52
Please do not use gadget from this thread with new DTLite version. It won't work as expected.

Did you try to reinstall DTLite?

21.09.2011, 09:57
Sure did. I tried uninstalling/reinstalling DTLite and I also tried uninstalling the bundled gadget before running the one supplied in this thread. I have yet to get either to work. I thank you for being so quick on the ball, Sway. Anything you can recommend?

21.09.2011, 10:41
Please specify your Internet Explorer version.

24.09.2011, 18:09
Internet Explorer version is

26.09.2011, 10:23
It seems it is compatibility issue with IE9. Our developers work on it now. I think the fix will be included to the next version.

29.09.2011, 01:42
Thanks so much for looking into it. Sorry to hear it's a basic compatibility issue, but it's great to hear that you and the team are on it. You folks are great! Thanks again.