PDA

View Full Version : "The Device is not ready"



steak-styles
26.11.2009, 21:16
I have been getting this problem with almost all of my disk images. I mount them, the program begins to install, it gets to a certain percentage and i get a message saying the installation could not be completed because "The device is not ready"
Nothing has really been changed in terms of system configuration, no hardware added or removed. I've tried uninstalling Daemon tools and reinstalling it twice now and I'm still getting the same error.
I'm running windows 7 with v4.35 of Dtools lite

Blazkowicz
26.11.2009, 21:27
Is the image still mounted?

steak-styles
26.11.2009, 21:44
Funny enough the image seems to unmount itself during installation, but not from daemon tools. Dtools shows the image as still being mounted but windows doesn't

Blazkowicz
26.11.2009, 21:58
Try to press on Load in DT.

steak-styles
26.11.2009, 22:05
I'm not seeing an option "Load"
From the menu i can see
Mount'n'Drive manager
Disc Imaging
Virtual Devices
Preferences
Recently used Images
Buy Now
Help and
Exit

Blazkowicz
26.11.2009, 22:30
It is under the virtual drive.

steak-styles
27.11.2009, 18:40
I tried pressing it but nothing happened, both before and after the error message

Blazkowicz
27.11.2009, 19:56
So where are the images located?

steak-styles
28.11.2009, 05:18
The Downloads folder in the My Documents folder. Internal HDD

sfletche
04.12.2009, 15:37
I have the same problem ,

Running Windows XP SP2
Dameon Tools 4.30.4.0027
SPTD 1.58

Along with the drive disapearing in windows I am getting these errors in the system event log

An error was detected on device \Device\CdRom1 during a paging operation.

The description for Event ID ( 9 ) in Source ( a14nishb ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: \Device\Scsi\a14nishb1.

Wyrd Darcnyzz
26.02.2010, 01:31
I am also having this problem, although it seems this thread is dead without a resolution. I'm running Vista SP2, with DaemonTools 4.35.5.0068. I am trying to install Empire Earth: Art of Conquest, and it gets to 82%, the quits, and says "Device is not ready." In My Computer, the virtual drive is listed as being empty, and reacts as such when you try to interact with anything in the image, saying "Please insert a disc into Drive E:\" or somesuch. When I got into the Mount 'n' Drive manager, it's still listed as being mounted. This is frustrating. It just seems to unmount itself for some reason.

Sway
26.02.2010, 10:18
Do you have such problem during installation from original disc?