PDA

View Full Version : Age of Mythology Issues



NuckChorris
23.12.2009, 07:19
I own a copy of Age of Mythology - but as I really dislike having my CD drive humming loudly when I am playing games, I prefer to use DAEMON Tools to mount ISOs. I had gotten DAEMON Tools to play nice with Age of Mythology once before, but that was on another computer running XP, with an older version of Daemon Tools. Now, on my new Laptop, running Windows 7, and the latest version of DAEMON Tools, I cannot make it work.

I am using the exact same disc image, just on a different OS and different hardware. I copied the ISO file from my old computer to my new one, and assumed it would still work. I had ripped the original AoM CD using BlindWrite, since it has some form of disc protection (SecuROM? SafeDisc?) which BlindWrite would supposedly not fail on. Well, although it took a good many hours to rip the CD (hence re-ripping is a last resort), it worked perfectly on that computer, once I had DAEMON Tools set up with YASU.

Now however, although I have the latest DAEMON Tools with the proper disc protection stuff enabled, the latest YASU installed and working its magic, and have gone so far as to disable the built-in DVD/CD-RW drive in Device Manager then set DAEMON Tools to that drive letter, it still won't work.

It keeps saying "Cannot Locate the CD-ROM: Please insert the correct CD-ROM, select OK and restart application" whenever I try to run it. My question is: has something changed in DAEMON Tools? What is happening here? I just want to be able to play my games as I wish, and not be bound to some fragile piece of plastic! Can somebody please help me?

Terramex
23.12.2009, 10:27
Have you you tried whether your original disc does work in Windows 7 at all ?