PDA

View Full Version : How do I delete SPTD from Regedit???



mjcn121789
31.12.2009, 09:12
"As last resort uninstall all software using SPTD layer (e.g. DAEMON Tools, Alcohol), open Registry Editor, browse the

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sptd key, set Start value to 4 (i.e. disabled), and reboot.

After reboot delete complete sptd key in services hive - you must enable all permissions on sptd/cfg key first.

Then reboot, and reinstall, beginning with SPTD layer. After reboot check correct SPTD layer installation (see above) before reinstallation of DAEMON Tools! "

Hi, I upgraded from Vista to Windows 7. I tried reinstalling daemon tools 4.10 but it was not compatible so i uninstalled it. I tried to install Daemon Tools Lite 4.35 but it gave me the windows 2000 error. So, then I installed the SPTD by itself and rebooted. Daemon tools lite still gave me the same error. I tried to delete the entire SPTD from the reg. I disabled the start and rebooted. Then I tried to delete the SPTD folder but it would not let me. What does "you must enable all permissions on sptd/cfg key first" exactly mean? How do I do it? Will you please give me step by step instructions for completely deleting/uninstalling SPTD from my computer so I can finally get Daemon Tools Lite to work properly???

Blazkowicz
31.12.2009, 10:19
I will update that help document with pictures in the next days, but here a step-to-step instruction for you.

1. Right click on SPTD key -> Permissions
2. Edit
3. Ownership -> Select your user and check the checkbox there and OK (or Apply)
4. Close menu and open it again (or else may be some problems)
5. Add your user there and give yourself "Full Access" and check the checkbox for the subkeys.
6. Close the menu and then you should be able to delete the key.

Alternatively you may try to install latest DT Pro, it fixes this issue automatically (at least it has done it when i tried it).

mjcn121789
31.12.2009, 16:17
I will update that help document with pictures in the next days, but here a step-to-step instruction for you.

1. Right click on SPTD key -> Permissions
2. Edit
3. Ownership -> Select your user and check the checkbox there and OK (or Apply)
4. Close menu and open it again (or else may be some problems)
5. Add your user there and give yourself "Full Access" and check the checkbox for the subkeys.
6. Close the menu and then you should be able to delete the key.

Alternatively you may try to install latest DT Pro, it fixes this issue automatically (at least it has done it when i tried it).

I clicked permissions and it showed me a list of things such as Creator owner, administrator, system, and user. I clicked on user and checked the full control box. It will still not let me delete it. Am I doing it correctly so far? What do you mean by add the user? Where do I do that? I see an add button but what exactly do I type in? Sorry but I'm all new to this.

Blazkowicz
31.12.2009, 17:18
In "Add" you enter "Everyone" or how your user is called in Windows.