PDA

View Full Version : SecuROM games do not work after uninstall of BioShock



sommergeorg
03.01.2010, 15:09
Hi!

I am experiencing a strange problem. After I uninstalled BioShock, which has been installed from a perfect image, activated and it worked perfectly from the image without the disc in DT 4.35.0308 and YASU 1.6.9040, I am unable to play any SecuROM 7.xx protected game anymore. All games are imaged from my original disc using the new SecuROM profile. The images are to be considered "perfect" as they worked before. It pops up the error "insert original disc instead of backup". I changed the info of my virtual drive (vendor, model...), changed device number. Reinstall game does not help.

Any ideas?

Terramex
03.01.2010, 15:44
Please try the official SecuROM Removal tool (https://support.securom.com/removaltool.html) to fix those timings problems.

sommergeorg
03.01.2010, 16:25
I already did. Nothing. Same problem as before. Do I need to uninstall all games protected by SecuROM and then run the official tool, or just the one which doesn't work?

Terramex
03.01.2010, 17:00
It shouldn't be neccessary to uninstall any SecuROM app before using the tool.
Just in case the removal tool didn't work proper (and only if you don't have other SecuROM protected titles installed that need online product activation and therefore have DRM license information stored in the registry):
- delete HKEY_CURRENT_USER\Software\SecuROM\Keys, reboot and try again

btw. have you tested whether the original discs work ?

sommergeorg
03.01.2010, 18:39
I tried your solution. Unfortunately it didn't help.

Here what I done:

I had this problem since a few days. Yesterday I installed Wolfenstein (the new one) from an image. It complained to insert the original disc. I changed the vendor name, model and firmware version of my virtual drive. Then Wolfenstein run perfectly. Then I loaded Outrun 2006 which also refused to launch before. It run perfectly too.

Then today I uninstalled Wolfenstein. Right after that Outrun 2006 refuses again to start.

It seems that I cannot uninstall any game that is SecuROM protected because it's looks like this would disable all others.

And I cannot use my original disc right now, as I am not home and have no physical access to it. That's why I use images :-)

evlncrn8
03.01.2010, 18:44
It seems that I cannot uninstall any game that is SecuROM protected because it's looks like this would disable all others.

actually thats inaccurate, there is no binding between one securom game and another, securom is not running unless you are running a securom exe, there used to be the user access service, which seems to be discontinued, but that is the only thing that could possibly be 'resident' when you are not playing a securom game, and there's no binding between the games, so uninstalling one should NOT have any effect on any others..

your problem is coming from somewhere else i think...

sommergeorg
03.01.2010, 21:01
your problem is coming from somewhere else i think...

You're right! I just found out what it is. It happens when I'm connected to the Internet when I want to play Outrun 2006. When I disconnect, the game starts as it should do.

It seems to be an online check :confused:
SecuROM can have either DVD check or activation or even both, but online check without activation??

Nevertheless, I'm relieved now that it works.

Thanks for all your help!!

evlncrn8
03.01.2010, 23:16
glad you solved it :), never seen online check without activation, it could be the game phoning home too perhaps..