View Full Version : Can anyone help?

24.02.2010, 20:32
I'm not sure if I'm following every rule with this post, but I'm really desperate. And I'm really frustrated, I hope someone can help.

All right, explain this to me.
I've done this before, I mounted my ME2 disc 1 to the SCSI Virtual Drive that Daemon Tools automatically detected. And the game setup launched itself. But both .iso (disc 1 and 2) files were on my desktop.
Now they are separately on different discs.

That was on a different computer.

Now when I try it on my computer, nothing happens. I insert disc 1, mount it to Virtual Driver that Daemon detected K: and nothing happens. I go to explorer and see "DVD Drive (K:)" when it's supposed to say "MassEffect2 (K:)"
Sure when I press the "mount" button, it says "Mounting image". And when I do so, the DVD Drives name changes to MassEffect2 for about 5 seconds after it changes back.
I tried copying both image files to my computer but it didn't let me, after halfway through a error message pops up and the transfer cancels.
I also tried mounting directly from the disc (not sure if that's the right metaphor) with MagicISO but it didn't let me.

I only have one CD drive (E:) and I don't know what the (K:) is there for.
As you can probably tell, I'm no expert at this shit. So please, how do I make this work?

24.02.2010, 21:21
Would you be so kind to tell us how you created this image or where you obtained it?

24.02.2010, 21:23
Would you be so kind to tell us how you created this image or where you obtained it?

That isn't important. You probably know why.
I'm just so frustrated with this, I've tried to get this to work for the past 6 hours and nothing.
Can someone just help me with this, please.

24.02.2010, 21:43
no, actually it is important...
how you made the image can be critical in diagnosing some problems, if however you didn't make the image and obtained it by other means (which i think is what you are skirting around) then you know how to fix the problem already.

24.02.2010, 23:00
As I said, the .iso file is fine. I tried it before on another computer with the same program and it worked.

(K:) is the virtual drive Daemon tools set up itself. (E:) is the physical drive where the image file exists.
When I go to explorer and try to expand (K:) after trying to mount the image file in it. A message pops up that says: "Please insert a disk into drive K:."

25.02.2010, 00:25
sigh, i can see this is going to go around in circles.. so

HOW did you make the image? if you can't answer this question then get the game and make an image.. then let us know what happens... because using the iso format for a disk with copy protection is pointless, the iso format can NOT record the specific information that the copy protection checks for...

27.02.2010, 21:51
I hope that helps:
(I know where you have got that image from, u leecher)
Uninstall MagicDisc (C:\program files\magicdisc\uninstall.exe or something like that);
Download most recent Daemon tools (lite should work too) & install it;
restart your computer;
mount the *.iso;

.:buy it if you like it:.

ever read the nfo files? they sometimes help

report if it works pls

gl&hf, theMax