View Full Version : Problems removing virtual drive

19.05.2010, 10:41
I have installed Daemon Tools lite version on my laptop running XP Pro SP3. Mostly it seems to work well. After having used it to mount an image and then working with it, I can unmount the image. However if I then try to remove the virtual drive (I’m only intending to use Daemon Tools occasionally), Daemon Tools seems to hang – the “removing virtual device” message is displayed, and stays displayed, but nothing happens. Windows Task Manager shows that the PC is basically idle, i.e. Daemon Tools isn’t actually doing anything. But still the message is displayed. I have to kill Daemon Tools with Task manager, and then I can’t reactivate the tray icon. The virtual drive is still shown in Windows Explorer.

However if I reboot the PC, I can reactivate the tray icon (I have disabled the autostart option), and now I can remove the virtual drive – it only took a second or two to remove it.

Hence I can get around the problem by rebooting. However it is irritating to have to do that. Any suggestions as to how I can fix this?

19.05.2010, 12:01
Hallo, and welcome to the forums.

Are there any errors in Windows Event Viewer (http://support.microsoft.com/?scid=kb%3Ben-us%3B308427&x=10&y=11) at the time the problem occurred ?

20.05.2010, 06:07
Yes, there were entries in the application part of Event Viewer for the 2 occasions it hung. They were type=error, source=application hang, category=(101), event=1002.

If I can work out how to post a picture in this forum, I'll include a screen print!

20.05.2010, 06:23
Image of event viewer page:

21.05.2010, 17:01
Does it also hang while removing when the drive wasn't in use before ?
Does this happen after the usage of any image (provided you've tried different ones) ?

27.05.2010, 11:39
Sorry about the delay in replying – a couple of non-computer related things came up which prevented me replying before now. I’m still interested in getting a resolution to this problem.

After many tests, multiple hangs and reboots (and a bit of bad language….), a summary of my results is as follows:

1. If a virtual drive is added and then removed, i.e. without mounting an image, it works O.K.

2. If a virtual drive is added, and an image is mounted and then dismounted, i.e. without using the image in any application (I held down the shift key when mounting the image to prevent my DVD playing software from autostarting), trying to remove the virtual drive results in a hang, regardless of which image is mounted – I tried several different images.

3. If a virtual drive is added, an image is mounted, and it is played with my DVD playing software (Dell Media Experience), then dismounted, and an attempt made to remove the virtual drive:

(a) if the ISO image file was a direct rip from a commercial DVD (either using DVDfab HD decrypter to rip to the hard disk and then DVD shrink to make the ISO image, or using DVD shrink to directly read the DVD and make the ISO image), it hangs.

(b) if the ISO image is not a direct rip from a commercial DVD (either it was made from a VHS recording, or the material was originally from a commercial DVD but has been further processed, i.e. reauthored), it works.

I should mention that all the ISO images I tried play O.K. in Dell Media Experience, and/or have been read into DVD decrypter to burn a (real) DVD, which then plays O.K. both on my laptop and in my DVD player, i.e. there would appear to be nothing wrong with the images.

But on occasions, Daemon Tools ran very slowly even when not removing a drive, although it usually eventually worked, e.g. once it took 2 or 3 minutes to add a virtual drive. And once when I dismounted an image and then tried to remove the drive, I noticed that the image hadn’t been properly dismounted – in “my computer”, the image was still mounted on the folders side of the screen, but shown as not mounted under “devices with removable storage” on the right side of the screen. It hung, and I couldn’t shut the PC down with the start menu – I had to hold down the power button to shut it down.

As a separate issue, on 2 occasions in the last few days when I have started Daemon Tools, Zonealarm has popped up saying that Daemon Tools has wanted to access the internet, which I denied. Why does it try to access the internet? I didn’t install the browser toolbar and I didn’t allow the installer to change the default search provider, and I have turned off the “check for updates monthly” option – and anyway, it’s been less than a month since I installed it.

27.05.2010, 13:46
Maybe some issues can be solved with the information provided here:
Security software solutions | DAEMON Pro Help (http://daemonpro-help.com/en/problems_and_solutions/security_software_solutions.html)

Please also send a message to our Support team with reference to this thread:
Send Message :: Disc-Soft.com (http://www.disc-soft.com/sendmsg)

27.05.2010, 15:02
I sent a message to the support team.

Unfortunately the Daemon Pro Help reference didn’t help. The only software it mentions that I have installed is Zonealarm, and mine is an older free version. I don’t have the Zonealarm toolbar installed.