View Full Version : Bioshock 1 NOT passing SecuROM checks anymore

20.05.2010, 15:48
Today upon trying to install BioShock I was greeted with a wonderful error message from Securom stating that i need to insert the original disc and not a backup when it tried to download the latest updates upon install, thus causing the installation to fail...

Once the installer exited out I:

Inserted my original BioShock DVD.
Opened up Daemon Tools Pro Advanced 4.36.0309.0160.
Created a new MDF/MDS image set using the "New SecuROM" option.
Mounted the newly created image in a vIDE drive.
Attempted to install BioShock from my newly created image set.

Please note that during the creation of the MDF/MDS image set the DPM analysis stage took about 10 minutes, completed without any errors and resulted in an MDS file 44KB in size...

OS is Windows 7 Ultimate (x64)
UAC is off
Account is member of admin security group, also tried 'run as administrator' option during image creation as well as during game installation


20.05.2010, 16:30
Does the original disc pass the check at all ?

If not: do you have other games installed also using SecuROM ?

20.05.2010, 16:51
Yes, the original disc passes the SecuROM check, the installer successfully auto-updates at the end of the install, and the installer finishes successfully...

20.05.2010, 17:34
I know it's a different situation, but maybe one of the measures mentioned in this thread (http://forum.daemon-tools.cc/f20/securom-games-do-not-work-after-uninstall-bioshock-25906/) can solve the problem.

In some cases chances rise a little bit using a mini image; transform your full image as described here (http://forum.daemon-tools.cc/f20/mini-image-tutorial-securom-7-a-22929/#post110456).

What vendor/model is the DVD drive you've used for image creation ?

EDIT: furthermore you can try this file (http://space.wismar-wacken.com/thomas/DPM/Bioshock/) instead of your own

20.05.2010, 18:29
Sony DVD RW DRU-840A

Over the past 2-3 months I've made & re-made MANY other MDS/MDF images using this drive & the current version of Daemon Tools. Games like F.E.A.R. Platinum Collection & Fallout 3 (GOTY) are among the games as well.


ok, so, i hate to say this but DT Adv Pro just failed me 120%

I downloaded the latest copy of Alcohol 120% (
I created a disc image set (MDS/MDF) using Alcohol 120% (note, 57KB MDS file size)
I mounted the image to my Daemon Tools vIDE drive
Installation FAILED...
I un-mounted the image from Daemon Tools
I enabled a single virtual drive in Alcohol 120% with the following emulation settings checkmarked:
Ignore Media Type, RMPS Emulation, Bad Sectors Emulation, Sub-Channel Data Fixed and Emulation, LaserLock Emulation
I mounted the BioShock image the the Alcohol 120% virtual drive...
Bioshock SUCCESSFULLY installed and passed the SecuROM check when it went to look for game updates...

3 letters come to mind...


I checked inside DT Preferences Advanced tab and can confirm the following checkboxes ARE checked: RMPS, SafeDisc, SecuROM, LaserLock, Hide CD-R

20.05.2010, 18:34
You do know size of MDS doesn't say anything about the quality of DPM, do you?

20.05.2010, 22:51
yeah, just pointing out that 2 separate programs have created MDS files with 2 different sizes and that there's something in them as opposed to a filesize <1KB which you tend to see with mds files that don't contain any DPM data...

anyhow... I'll try that other mds file listed above and see what happens...

it just makes no sense that other games work fine, but this particular game is having issues...