PDA

View Full Version : Need Windows 2000 + 1.60 SPTD driver



asdfjklö
27.06.2010, 13:07
Greetings.

I know, this is a pretty known issue here and I found lots of postings and threads regarding this problem, but after hours of frustrated search-try-error-search again-cycles (don't mention the dozens of reboots) I'm still having the same problem:

Daemon Tools Lite won't start anymore, it just accuses me not to have Windows 2000 (or higher) or SPTD 1.60 (or higher) installed. The funny thing is - I'm using Daemon Tools for a couple of years now. I never had a problem like this before and - honestly, I didn't change any security-relevant software on my PC (just installed the game Perfect World, that's it) - so I am really wondering what's going on here.

Security relevant software installed:
Windows XP Professional SP 3, 32 bit
Ashampoo 1.20 as Firewall (since 2-3 years, never any problems encoutered in combination with DTLite)
Avast Antivir 4.8 as Antivirus software. No problems in combination with DTLite encountered so far
Spybot S&D 1.6.2.46 - same as above, never encoutered any problems with DTLite

Things that I've already tried:
Obvious things first: I uninstalled DTLite, downloaded SPTD 1.69 from duplexsecure, installed it without any problems, reboot, installed DTLite ---> Internal Setup Error code 14
Uninstalled Perfect World - no changes.
Uninstalled SPTD, deleted it manually from registry and disk as suggested in this forum, reinstalled DTLite (with sptd included) ---> Internal Setup Error code 14
Disabled any non-microsoft-services with msconfig, rebooted, tried to install DTLite ---> Internal Setup Error code 14
Startup PC in secure mode and install DTLite - which works just fine. Then Reboot ---> Need Windows 2000 + SPTD 1.60 installed.

So it seems to me, that some software is blocking the installation (and execution) of DTLite but since I installed nothing new and never had any problems with this software configuration before I am really at the end of my wisdom here. The only option I have left is format C: which I really don't want to use, so I hope that somebody here can help me to get things up and running again.

Cheers

Blazkowicz
27.06.2010, 15:33
Do you use ThreatFire, ZoneAlarm toolbar?
As you already figured out, internal setup error means some security software is blocking.

asdfjklö
27.06.2010, 16:27
I never used ZoneAlarm (with or without toolbar) and since I don't even know what Threatfire is (sounds like firewall) I am pretty sure I don't use this one either.

Oh and I forgot to mention, that the Windows-internal Firewall is deactivated.

Blazkowicz
27.06.2010, 22:34
Please post the following details of the following two items:
1. Start -> Run -> msconfig -> services -> Hide all Microsoft services
2. In msconfig -> Startup

asdfjklö
28.06.2010, 13:34
Services:
1st Part (http://img156.imageshack.us/img156/9216/services1.jpg)
2nd Part (http://img180.imageshack.us/img180/3302/services2.jpg)

Startup:
1st Part (http://img532.imageshack.us/img532/8607/startup1.jpg)
2nd Part (http://img143.imageshack.us/img143/9681/startup2.jpg)

dave lister
29.06.2010, 00:43
I'm having the same issue on an new install. Also, Daemon doesn't even show up in the add/remove list, I have to uninstall from the parent folder. For comparison, here are the Services and Start Up on my XP SP3 32 bit.http://i813.photobucket.com/albums/zz59/knebworth79/Tracker%20Photos/Start.jpghttp://i813.photobucket.com/albums/zz59/knebworth79/Tracker%20Photos/Services.jpg

dave lister
29.06.2010, 00:54
It figures, after I post I think of more information. I saw on asdfjklö's System and Start Up that we both run Avast. Now, on two other computers in the past I have installed DTL without any problems, and on those computers I was running Avast version 4.8. The computer I'm having trouble with today has Avast 5.0. (I don't know what version of Avast asdfjklö is running, but if he is running 5.0, this might be a clue to the source of the trouble.)

Hope this helps.

asdfjklö
29.06.2010, 20:07
Seems reasonable, that Avast is possibly the troublemaker since all my services are stopped / deactivated except the Avast-Services. But in my case you are wrong dave.

Here is what I did on this funny afternoon (this will be a lot of text I fear):

1.) Uninstalled Avast! Antivir via Control Panel ---> Software and with a special tool (http://www.avast.com/eng/avast-uninstall-utility.html)to remove every trace of the Software.
2.) Uninstalled my Ashampoo Firewall
3.) Uninstalled Spybot S&D. So nothing should be able to get in the way of DTLite anymore, right? Well to make sure I checked it with EnumProcess (http://www.trolly.homepage.t-online.de/EnumProcess.exe)
4.) Started the installation of SPTD 1.69 from duplexsecure (http://www.duplexsecure.com/downloads/). The Program stated "Current SPTD installation cannot be validated by setup. It is recommended to disable SPTD service and rerun setup after reboot. Do you want to disable SPTD service now?". I clicked on Ok and after that...
5.) Reboot
6.) Startup PC in secure Mode
7.) Continued the SPTD-Setup which said something like "No SPTD Version found, what would you like to do?" I clicked on "install" of course and it seemed to be successful. And after that...
8.) Reboot
9.) Startup PC in secure Mode
10.) On Startup Windows stated "Hit RETURN if you want to continue loading SPTD.sys" and of course I hit Return.
11.) Okay, we are getting to the funny part now: I started SPTD Setup again just to check what it would say regarding the installed Version and voila, it displayed "SPTD 1.69 is already installed and running on your system." Happily I quit the setup and went on to install DTLite.
12.) After the first setup screen I got the frustrating "Internal Setup Error code 14" error. Just out of curiousity I tried starting SPTD setup again and this time it came up with the message from point 4 (can not recognize SPTD version and so on).
13.) After bashing my head against some random stuff lying around on my desk I decided to install DTLite without installing the 1.69 SPTD-Drivers first. So I once more started SPTD-Setup, disabled the service and after that...
14.) Reboot
15.) Startup in secure mode without running the SPTD-Service
16.) Installed DTLite (which went smoothly) and after that... yeah you guessed it:
17.) Reboot
18.) Startup in secure mode once again (and of course hit the Enter-key for SPTD.sys)
19.) Run DTLite and... as if by a miracle it worked!
20.) Reboot
21.) Startup normally and waiting for DTLite to load... but no happy end. The Error displayed was once again (roughly translated into english) "You need to have at least SPTD 1.62 or Windows 2000 installed. Kernel Debugger must be deactivated." Hello? What security software could still interfere with Daemon Tools? I'm practically naked online now. I don't have a Firewall installed, I don't have an AV-software installed, I don't even have that crappy Windows-Firewall running.
22.) By the way: The CD/DVD-Drive is correctly created, displayed and also accessable (I assume this was done after running DTLite succesful in step 19), but of course I can't mount anything because the main program won't start.

So what the hell am I supposed to do, to get DT running again? Slaughter a black cat, paint a pentagram with it's blood on graveyard-ground and do a nude dance around it at midnight while waving my PC over my head?
Okay, forget the last part, but honestly it is getting more and more troublesome to get Daemon Tools working again. I would really prefer to continue using Daemon Tools, but if there is really no way to get it running again, I have to switch to another Virtual-Drive software.

Conclusion: I don't think that a security related software is causing this problem. A wrong SPTD-installation or a partially SPTD-incompatibility with Daemon Tools seems more likely.

So if you have any clue regarding this problem I would be really thankful.

cheers

Senfgurke
30.06.2010, 22:25
OK just 1 thing to think about.
I have the same prob but didnt install DT new.
It was working perfectly fine and one day it refused running with the "windows 200 and ..." line. Something must have changed.
I remember doing some Windows Updates letely......

asdfjklö
01.07.2010, 01:27
I deactivated Windows Updates long ago because it keeps getting on my nerves trying to install unnecessary software (I don't have any problems with updates, but just keep installing new software and tools and whatnot... definite no).

Sway
01.07.2010, 10:30
Did you try to go through ALL steps of this guide - Registry and SPTD problems | DAEMON Pro Help (http://www.daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html?)

asdfjklö
01.07.2010, 18:02
Did you try to go through ALL steps of this guide - Registry and SPTD problems | DAEMON Pro Help (http://www.daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html?)

Yes, I followed steps 1 to 17 to the letter and I just did it once more just a couple of minutes ago with following results:

DTLite Uninstall went smoothly
SPTD registry-uninstall went smoothly

After that i rebooted and checked the registry for
HKEY_LOCAL_MACHINE\Software\19659239224e364682fa4b af72c53ea4 (DT Lite)
Didn't find it, so all seems to be according to plan.

I downloaded this (http://www.disc-tools.com/download/sptd) SPTD Stand-alone installer mentioned in your help above.

I installed SPTD and rebooted of course.


If it says no SPTD layer version detected, or gives an error message, DO NOT install DAEMON Tools!

Please leave a message in our forum if you still have problems.
According to this I started the SPTD-Installer again and it came up with the error message mentioned in the quote above, so I hereby leave a message again, that this problem is still not solved. If you want a clear view of the error message just take a look at my screenshot (http://img121.imageshack.us/img121/7204/77381940.jpg). As advised I didn't even try to install DTLite this time.


I will try Steps 1 to 17 from your guide again but this time I won't use the SPTD stand-alone installer. Instead I will try the DTLite installer, which should also have SPTD integrated. Results will be posted soon.

asdfjklö
01.07.2010, 18:37
Sorry for double-posting but I didn't find an edit button.

Well, as promised, I completed steps 1 to 17 of the guide, checked all other stuff (registry permission for Enum-Folder and so on) and then installed DTLite directly.
The installation went smoothly - at least I got rid of this annoying "Internal setup error code 14"-error. Yay.

After succesfull setup and rebooting I got (as expected) the following error on startup which says something like "You need at least Windows 2000 or SPTD 1.60...". For the exact message take a look at my screenshot (http://img339.imageshack.us/img339/8223/77048292.jpg).

I'm open for any suggestion how to solve this problem, but I don't know what I could do anymore. -.-

Senfgurke
02.07.2010, 07:18
OK so it seems to be no windows update thats to blame for the DT-Errors



I deactivated Windows Updates long ago because it keeps getting on my nerves trying to install unnecessary software (I don't have any problems with updates, but just keep installing new software and tools and whatnot... definite no).

Hosslad
03.07.2010, 11:19
Zone Alarm Toolbar caused the problem for me.

Latest Zone Alarm update instals their toolbar unless you specifically untick the instal box.

Once this thing is installed, Daemon won't run.

Disabling the toolbar (in IE or whatever) makes no difference.

Removing the Zone Alarm Toolbar in control panel add/remove programs does the job, and Daemon now runs fine.

No need to remove Zone Alarm itself, just the tool bar.

I really wish all these 'safety software' people wouldn't stick all sorts of hidden crap in their updates !!