PDA

View Full Version : Daemon Tools 3.47 on Windows x64



888
16.07.2010, 09:31
I admit, I have avoided any newer versions of DT until now (because of problems with SCSI pass-thru driver).
Anyways DT3.47.0 worked great for me through all the years and windozes, from 2000 thru XP (briefly) and 2003.
But I have just built my new "upgraded" main machine with 6-cores and 16GB of memory, so obviously tomorrow I'll have to install Windows Vista Lite x64 (aka Windows 7) along linux, hence my question:
Will DT3.47 work on Windows x64?
If so - any problems because of 32-bit emulation?

I'd really hate to change from DT to another one, but if the only option is to use DT4.x (with SPTD) then I'll have no choice :(

Sway
16.07.2010, 10:05
What exactly Windows x64 version do you use? Vista or 7?

DAEMON Tools 3.47 is very old version. It isn't compatible with Windows Vista/7 and 64 bit systems. Use the lastest DT versions.

888
20.07.2010, 01:25
What exactly Windows x64 version do you use? Vista or 7?

DAEMON Tools 3.47 is very old version. It isn't compatible with Windows Vista/7 and 64 bit systems. Use the lastest DT versions.

Win 7 x64
Yes 3.47 doesn't work there.
As I said, I don't want any latest DT version because of the SPTD problems with other software.
I solved it by switching to Elby's latest Virtual Clone Drive. It runs great on Win 7 x64, doesn't require SPTD and coexists/works nicely with all other software (unlike latest DT with SPTD).

Sway
20.07.2010, 09:47
As you wish :(
FYI: we plan to implement a possibility to work without SPTD for the next DT versions.

888
21.07.2010, 17:08
FYI: we plan to implement a possibility to work without SPTD for the next DT versions.
Good!
I'm sure there are some positive aspects of using SPTD, but personally I know negative ones only... IMHO tying DT to SPTD and forcing DT users to use SPTD was a mistake (just look at this forum how many problems posted here are SPTD related).
I'll be happy to go back to DT as soon as you guys have non-SPTD version available again :)