View Full Version : SPTD errors

05.08.2010, 10:15
I run XP Pro and I recently got a virus on my computer.

After a series of scans between MalwareBytes and Sophos, I've deleted all but one virus. This last virus is stuck in my memory, according to Sophos (which was the only one that picked this virus up)--it's specifically in ntdll.

I was continuously getting a blue screen unless i stopped the SPTD from running in safe mode. I was able to disable it, thus letting me run windows regularly. However, when I tried to uninstall the driver, it seems to have caused more problems.

I went into the device manager > view > show hidden devices
right clicked sptd and clicked uninstall

when i rebooted, it gave me the same blue screen. when going into safe mode, it still prompted me to hit Esc to stop the driver from running. but now, the driver doesn't show up in my device manager and the .exe file I've tried to open doesn't seem to find the driver on my computer either.

does anyone have ANY ideas? I know I have to do something in my registry to fully delete these corrupted files, but I don't know much about this.

05.08.2010, 10:47
Registry and SPTD problems | DAEMON Pro Help (http://www.daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html)
Note that your OS might be corrupted by virus activity.

05.08.2010, 18:42
At step 6, Replace owner on subcontainers and objects, I get a message that says "Registry Editor cannot set owner on the key currently selected, or some of its subkeys."

05.08.2010, 19:23
Did you start regedit with administrator privileges?
You also rebooted after setting Start value to 4?

05.08.2010, 23:43
okay, i managed to do it, though that one step didn't seem to work correctly.

so as far as daemon tools is concerned, my computer seems to be fixed.

but i still have these trojans in my memory and i have no idea how to get them out. might just cut my irritating losses and install Ubuntu