PDA

View Full Version : Save settings in a well known place to allow the use of NT security



oglimmer
20.04.2004, 17:48
The newest patch of Sacred (1.6) disables the "Emulation" settings from daemon-tools automaticly at startup.

Therefor daemon-tools are ineffectiv to use with Sacred.

My suggestion:

Save the settings in a well-known registry-key or file, so I'm (and the rest are) able to use NT security mechanisms to prevent Sacred from changing the settings.

dexter
04.05.2004, 14:01
yeah - just like with anti-vir soft - applications run as user are not able to change parameters ar shutdown admin's applications, you do that guys :)

Development
07.05.2004, 11:27
There is better way - run your games only under non-admin account.
If they require to be admin - return them to the shop.;)

dexter
08.05.2004, 18:10
I did try that and it didn't do any good - dt3.46 was launched as admin on WinXP and Sacred 1.6 as regular user but still the game keeps disableing RMPS and Lock DLL options of deamon tools, so we're back where we started :|

Andareed
08.05.2004, 18:41
Try to (temporaryily) kill daemon.exe and rename it to daemon.old.

Development
13.05.2004, 14:00
Before running game as user you need to delete all Protect CD5 drivers and reboot (sshdrv*.sys), because they were already installed under admin and now used under user account.

dexter
20.05.2004, 22:23
been out for some time but i'm back

perhaps it'll seem a bit lame but i'll ask anyway
i've found the SSHDRV* device driver in device menager so now i can restart the driver but :
1. you mentioned deleting all Protect CD5 drivers and then rebooting the driver but in driver details there is only one file listed and it's SSHDRV77.SYS so not sure what to do next
2. if i restart the SSHDRV* as a member of admin group won't it be run as admin again, or should i just set it to load the driver on demand becouse now it is loaded with SYSTEM previlages

Development
22.05.2004, 10:19
I was meaning you need delete it completely from system32\drivers folder and reboot. Then login as non-admin and try to run.