PDA

View Full Version : Unable to add adapter on Windows 7 new install.



JamesR404
31.08.2010, 11:02
I've got an annoying error here, I'm trying to get Daemon Tools to work on this new Windows 7 laptop I've got, but after installing I keep getting this error:

"Unable to add adapter."

1009

Following some hints on google I tried to uninstall, reboot, install, check device manager for any device issues - but none found.

Anyone have any other hints for this issue?

What services and stuff are required for Daemon tools to be able to add an adapter?

Thanks much to all!

thuysanboy
01.09.2010, 18:00
I have exactly the same error as you did. I think it's from right control of software in windows 7, it has prevented Daemon tool to add new virtual device. I havent found any solution yet.

Sway
01.09.2010, 19:52
Registry and SPTD problems | DAEMON Pro Help (http://www.daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html)

iniduoh
04.09.2010, 11:11
I have the exact same error. The link provided seems to be how to uninstall SPDT. Please help.

Blazkowicz
04.09.2010, 11:33
It also describes registry permissions at the end of the document.

JamesR404
21.09.2010, 23:28
All right, I'll check if those steps (especially the registry permissions) help resolve the error.

Will let you know! =]

Debuger
15.10.2010, 11:19
I have same problem
I completed all steps from here :
DAEMON Tools Professional Help: Registry and SPTD problems
I have tried various versions of spdt driver (1.74 1.62 1.59)
the result always the same :
Unable add adapter. Invalid device

Magnusekström
15.10.2010, 17:59
I have the very same problem.
Running Windows 7 32-bit on a new Lenovo T410.