View Full Version : DVD drive won't read

27.09.2010, 00:19

Okay before giving me a standard answer I would like to point out I've googled alot about this. Please read.

Okay, I found my DVD drive not working after I installed Daemon Tools. I tried uninstalling it but without luck. The drive is showing under "My computer" but I can't open/play it. Whenever I try to it pushes out my DVD drive and tell me to place a DVD/CD in it. I don't have any other drive cloning software installed.

I read this guide. Your CD or DVD drive can't read or write media (http://support.microsoft.com/kb/314060/). The "Fix it" tool didn't work for me. For some reason the UpperFilters and Lowerfilters are not in regedit either. And yes, I am under DVD/CD-ROM drives but they are not showing(?)

I also tried reinstalling the drivers but didn't work.
When I go into BIOS the drive is showing.

I tried to change the letter in Drive Management but without succes.

My computer is only 2 months old so it would be strange if the drive itself was defect. I can't boot from the drive as well so repairing Windows 7 is not a possibility (if it would even work).

How do I get my drive to work again?

Sorry for spelling mistakes. I'm not English.

27.09.2010, 00:28
So you tried different disks? If so and all doesn't work and as you said you can't even boot from it (hopefully you set your BIOS to boot from CD/DVD), it is most likely the drive.

Booting from disk is before Windows loads and therefore DT/SPTD is not active at all.

27.09.2010, 00:52
Yes, it is set to boot from the disk and I have tried several disks.

But how come that be? The computer is only 2 months old. And funny enough this problem only occured after I installed Daemon Tools.

Isnt' there any way to fix it?

27.09.2010, 00:54
You may try to uninstall SPTD and DT, but I doubt it will work as I already have explained, no boot from (with a bootable disk of course) after POST, normally means drive broken (most likely the laser).

27.09.2010, 01:23
Thanks for the answers.

One last thing:

How come it be that I can't see the UpperFilters and LowerFilters in regedit?

27.09.2010, 01:38
I guess you are in key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Normally UpperFilters and LowerFilters should exist (most without content).

But as the drive doesn't read it and is displayed in My Computer, registry key is fine.

27.09.2010, 10:32
In case you cannot boot your PC from this DVD drive, it means exactly that the drive is broken.
Sure, there is a small chance that the problem is related to your PC's motherboard.
First you need, test your system with some other DVD drive. Such simple test will show where is the problem.

27.09.2010, 11:20
But I mean... If it was broken shouldn't it at least try to read? When I put a disk in it makes absolutely no noise. Just blinks 1 or 2 times.

27.09.2010, 12:59
Chances are small, but please unplug the drive's power supply cable for a few seconds - when the PC is switched off.

Which brand/model is the drive ?
Have you altready tried another S-ATA connector ?

Beyond that everything has already been mentioned: try another drive and/or try your drive in another PC.

27.09.2010, 21:37
It's an Optiarc DVD RW AD-5260S.
I'm getting a new one soon (free) so we will see if it was the drive itself which was damaged.

By the way, is it possible to formate Windows without the drive working? In that case, how? I do have the installation DVD which came with but if it turns out that it's not the drive which is the problem then what am I going to do?

Thanks in advance.

28.09.2010, 14:57
In this case create an ISO image of your Windows 7 at a friend's PC and use e.g. the tool
Windows 7 USB/DVD Download Tool (http://wudt.codeplex.com/) to create a bootable Windows 7 USB stick.

If you get a message that your image "is not a valid ISO file" (mostly when using custom ISOs)
search the web for workarounds or alternative methods.

29.09.2010, 11:21
Okay, the new drive is working perfectly :). Thanks for all the great answers!

Close the thread please.