View Full Version : Actual drive disappeared, but DT virtual device doesn't work either

28.02.2011, 17:27
After a repair install of Vista, my DVD drives disappeared. Device Manager has a yellow exclamation point next to the drives and says the 'driver may be corrupted'. When I click Update Driver it says the 'driver is up to date'.

I tried the Microsoft Fix It tool which also says it's a driver problem, but that says the driver install it tried failed. Note that the drives themselves work when I load from another copy of Vista on another hard drive, and I can also boot from them. It's only this one copy of Vista that's messed up. I even moved it to a different computer case, same thing - from another hard drive the DVD drive works, but this one says there's a driver problem.

I can't do another repair install since you have to initiate those from within Windows.

In Daemon-Tools, when I click add SCSI Virtual Device, the new drives I add are visible in Device Manager but not in file explorer. Device Manager has the same yellow exclamation points next to the drives, and has the same 'driver may be corrupted' mesage. Under driver details, the virtual drives have the same drivers listed as the physical drive:

Is there anything else I can do to debug this issue and get the Virtual Device working?

01.03.2011, 09:05
No virtual drive in My Computer | DAEMON Pro Help (http://www.daemonpro-help.com/en/problems_and_solutions/no_virtual_drive_in_my_computer.html)

01.03.2011, 21:12
Yes thanks, I had actually done those steps prior to making my post. Under drive details I don't have the storprop.dll and redbook.sys listed for either the phyiscal or virtual drives, only the two files I listed above. Where do I find these files?

When updating the driver from the windows\inf location it says "Windows has determined the driver software for your device is up to date." It gives the same message for both the physical and virtual drives. I deleted infcache.1 and tried again but there was no change.

I repeated the update driver steps after copying the files from the FileRepository\cdrom.inf_b2045cb8 and FileRepository\mshdc.inf_1d87dda2 folders to windows\inf, but the result was the same.

05.03.2011, 09:23
Can anyone offer further advice on this?

14.03.2011, 13:15
Happened to me. I even tried to remove the drivers and reinstall them and still wouldnt work. Even my external 2tb drive would work. I tried a system restore and it seemed to fix the problem.

14.03.2011, 14:31
I was able to fix this via one of two things (not sure which one was the solution).

First I followed one of the instructions from this thread:
DRIVER NEEDED: TSST sh-s223f (Windows 7) - DriverGuide Support Forums (http://forums.driverguide.com/showthread.php?t=60337)

Which was to download xp_cd_dvd_fix.vbs (http://www.dougknox.com/xp/scripts/xp_cd_dvd_fix.vbs) and run the command "wscript.exe xp_cd_dvd_fix.vbs".

I also rebooted from another Vista install and deleted the driver files like cdrom.sys (since they were protected). I copied the files from the good install to this one.

After this the drives reappeared.