PDA

View Full Version : Cannot remove virtual devices or mount iso



ryanmc
19.04.2011, 17:21
I am using Daemon Tools lite 4.40.2.0131 (see attachment) on Windows 7 64bit.

When I first installed it I added a virtual device and mounted an image. I have left that image mounted for about 2 weeks, but now I need to mount another image. When I opened up Daemon tools I noticed that the list of virtual devices is empty (see attachment), so I clicked the button to add a new one. A screen popped up saying it was adding a new device and then it went away, but still the list was empty.

So I opened up Windows explorer (see attachment) and I can see that I now have 3 virtual drives (F, K, L), but no way to mount anything because they are not listed in Daemon Tools, I also cannot remove them because they are not in the list.

What am I doing wrong?

Blazkowicz
19.04.2011, 17:28
Is there any error in device manager?
Also you may try to switch to Advanced Emulation for testing purposes.

ryanmc
19.04.2011, 17:43
Is there any error in device manager?
Also you may try to switch to Advanced Emulation for testing purposes.

No errors in the device manager.

After enabling Advanced Emulation, and rebooting the computer, All the virtual drives, except one, have disappeared, and the one remaining now shows up in Daemon Tools. I guess its working now.

Should I leave Advanced Emulation enabled or can I disable it now?

Blazkowicz
19.04.2011, 18:29
If you don't have any error with Advanced Emulation (like with specific security software), then you can leave it enabled.