View Full Version : Trouble Installing

26.05.2011, 17:04
Last night I downloaded DTLite from filehippo and ran the install, but Comodo Firewall (Defense) gave a buffer overflow alert for the file, which I accepted. When I tried to run it again, I got the same alert and eventually nothing at all: the install would disappear (stop) after accepting the Agreement screen. Today, I downloaded it from the Daemon site, but the disappearing act continues. I figured adding the install file to the Firewall and Defense trusted apps would fix it, but it the latter said it was already there and it still doesn't run. Right now, the file shows in the Defense + Events list as Shellcode Injection. Any ideas?

26.05.2011, 17:22
Disable Defense+.

26.05.2011, 17:33
That worked, but I got numerous Alert boxes like the one attached. Don't know if it's Daemon or Comodo.

26.05.2011, 17:50
Hmm.. I posted a reply but it's still not showing, though Manage Attachments shows my screenshot as uploaded.

In any case, I disabled Defense and installed DLite, but got numerous Alert boxes about a buffer overflow. Not sure if that's Comodo or Daemon. See attachment.

27.05.2011, 07:14
If you see such Alert box, it means that Defense+ is still active. Please disable it and reboot.

27.05.2011, 17:30
As I indicated, Daemon installed, as I clicked on "skip" with the alerts. The problem seems to be Daemon won't run unless Defense is disabled. Didn't used to be that way, as I recall, but it's been some time.

27.05.2011, 21:08
It isworking with D+.

First, you have to add all executables to trusted files on D+ tab.
Second, you have to open D+ settings and add them to exclusions in "Execution Control settings".
Last, add it to trusted files on the firewall and create a rule that allows the traffic.

The DT and COMODO are working great without any conflicts.

I suggest you to grasp the settings of your security software before using it.

27.05.2011, 21:43
Thanks for the pointers. I got everything easily enough, and it appears Daemon rules under the firewall's Network Security Policy > Application Rules were automatically created. It runs without warning now.

I very appreciate much your helpful advice. I'm just disappointed you ended it with an ignorant, cheap shot.