View Full Version : "Error in command line" - No programs will start, computer broken!

29.05.2011, 01:00
Hey guys,

After installing Daemon tools, whenever I try and open any program (.exe) on my computer, I get this error message:

DAEMON Tools Lite
Error in Command Line.

I've already uninstalled Daemon tools completely, and no Daemon tools processes are running in the background.

I've tried searching the forums, and although similar people have had the same problem, their fix doesn't work for me. I can't open regedit, and this fix:

@="\"%1\" %*"

doesn't work. Also, when I try the "assoc exe=exefile" fix, I get this error in command line:

Access is denied.
Error while processing: .exe

Note that I did this by going to file -> New Task in Task Manager and then hitting control-enter, since I can't actually run cmd.

29.05.2011, 13:26
Does the current user account principally have sufficient access rights ?

If not, after you've adjusted that please do both "fixes" in command line:

assoc .exe=exefile (hit Enter)
ftype exefile="%1" %* (hit Enter)

29.05.2011, 19:40
Yes, I'm logged on as administrator and I still cannot perform those fixes (getting the error described above)

30.05.2011, 01:19
Sorry for the double post, not sure how to edit posts.

Other things to note:

Right clicking on command line doesn't give a 'run as administrator' option. I believe I'm running an elevated command prompt since its starting in: C:\Windows\System32

Also, I would be happy to simple re-install the OS at this point since I can't do anything on the computer. However, I can't find my Windows Activation Key, and I could recover it on the computer from the registry, except that I can't run any programs so I can't get to it.

Any Ideas? Thanks a bunch guys I'm totally stuck at this point

30.05.2011, 11:56
'Access denied' errors can also be caused by security softwares (though that security software should have also prohibited the changes which result you're facing now :confused:).

Have you also tried the fixes in Safe Mode with Command Prompt ?

Which OS are you using ?

If everything fails please have a look here (http://windows7migration.info/index.php?option=com_content&view=article&id=531:regedit-as-offline-registry-editor&catid=42:4sysops&Itemid=61).
You need to load the SOFTWARE hive to be able to edit the Classes subkeys.

01.06.2011, 00:28
Sorry, the OS is Windows Vista, and I don't think any security software is installed on the computer

I booted the computer in Safe Mode, and performed the above fixes successfully but still cannot open any exe file (or the registry).

I tried following the guide, but unfortunately my windows Vista Reinstallation CD does not have a "repair your computer' option.

I simply want to wipe the OS and install a clean version of Vista, any idea how to get the activation key from the registry?

Thanks for all the help so far

01.06.2011, 14:07
Here you can find a Vista ISO with RE only: Windows Vista 32-Bit (x86) Recovery Disc (http://digiex.net/downloads/download-center-2-0/applications/956-windows-vista-32-bit-x86-recovery-disc.html)
One can simply integrate a program like e.g. ProduKey by Nirsoft into that ISO.
Later today i'll upload such an ISO (~120MB) and send you the link via PM.
Boot with that CD, open command prompt and enter X:\Key\produkey /external (X = the letter of your optical drive).
Of course you can also use regedit with that ISO and check your Classes before doing a fresh install ;)

02.06.2011, 01:06
...also check HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\.exe\
if present, delete the UserChoice key.

To open the HKEY_CURRENT_USER hive navigate to your userprofile folder and type
the file name of the hidden ntuser.dat manually.