PDA

View Full Version : Can't activate "advanced emulation".. not even got the option?



jordanmoore
15.08.2011, 22:11
I've got a program I bought which requires the DVD in order to install it or even use it - and quite a few of the files are on the disk too.
Well I left this disk in my bag for far to long and it got scratched to high heaven.. after like a day of trying and cleaning I've managed to create a 100% sector to sector identical copy of the DVD as an ISO.

Now when I emulate this ISO as a dvd it tells me that it's not a real DVD - correctly so. But I used to have a while back Daemon Tools Lite, and when I turned "Advanced Emulation" on the ISO would work correctly.
Well now I need to use the program again, so I've downloaded Daemon Tools Lite again - but I can't get it to work. Now I'm an IT guy, but I really can't figure this out and it's getting the better of me!

I install it with SPTD with the setup and restart immediately afterwards. I run daemon tools lite and go into the settings down to "advanced".
But Advanced Emulation is nowhere to be seen in that list. All I have listed there is "RMPS", "SafeDisc", "SecuROM" and "LaserLock". And they're all disabled (greyed out).

I'm really starting to get frustrated with this now and would greatly appreciate it if anyone could help me figure this out!

Other Notes:
Microsoft Security Essentials
ThreatFire
COMODO Firewall
PeerBlock
Windows 7 Pro (64bit, legitimate)

Sway
15.08.2011, 22:15
Please specify your DAEMON Tools version.

jordanmoore
16.08.2011, 00:14
Currently installed is:
4.41.3.0173

Interesting to note though, I clicked into the "about" screen to find out my exact version and it's reporting "SPTD Version: Not installed". I told the setup to install this, and I already installed the latest version (in 64bit) previously (before this installation).

Any ideas guys?

Terramex
16.08.2011, 00:42
@jordanmoore
In latest DT lite version Advanced emulation isn't separately selectable anymore in Preferences/Advanced (http://www.daemon-help.com/en/user_interface_lite/tray_icon_right_click_menu_lite/preferences_lite.html).
Instead it's automatically activated when installing SPTD or -if you unchecked SPTD at installation- at the
latest as soon as you're creating a virtual SCSI drive.
As the advanced emulation options are greyed out it seems SPTD isn't working / wasn't installed properly.
(BTW. the emulation options most likely wont help with your ISO problem, but maybe the virtual SCSI drive
does the job where the virtual DT drive is detected by the copyprotection check).

Don't know whether it got resolved in the meantime but there was a conflict between ThreatFire and SPTD:
Security software solutions | DAEMON Pro Help (http://daemonpro-help.com/en/problems_and_solutions/security_software_solutions.html)

There are also known issues with the Defense+ module of Comodo Internet Security:
http://forum.daemon-tools.cc/f19/cant-create-ide-scsi-drives-28469/
Have you only installed the Firewall module ?

jordanmoore
16.08.2011, 01:23
Maybe it is the SCSI solving the problem - I have to admit that my main field of knowledge is not in this area.

As for threatfire, I've had the two of them working before (an older version of DT) a few months ago - but regarding COMODO, I never had that software the last time that it worked. MSE was also installed when it worked last.

I have COMODO Firewall with Defense+. Firewall is set to "safe mode" and the "Defense+" is set to "Clean PC Mode".

I'll give SPDT another crack tomorrow and hopefully that should then automatically start working as you say it's automatic now.
I guess that considering COMODO seems to be the greyest area here, I'll try disabling that if I can't get it to work by other means.

evlncrn8
16.08.2011, 02:16
If its really an iso it probably wont pass the protection check

jordanmoore
16.08.2011, 12:57
If its really an iso it probably wont pass the protection check

It is an ISO, and the ISO used to run correctly with advanced emulation enabled. Without advanced emulation it fails to pass the protection check.

jordanmoore
16.08.2011, 13:18
I've managed to get STPD 1.78 installed (and it shows up in the advanced screen), I managed this by disabling "Defense+" in COMODO. All of the check boxes are still disabled.

However my ISO still recognises that it's a "counterfit" DVD and fails to install/boot.

Which DT Lite version should I download to have "Advanced Emulation" back?

Terramex
16.08.2011, 14:32
So you were able to create a SCSI drive now, but the emulation options are still greyed out ?

Have you adjusted the Defense+ Security Level slider to Disabled, or have you ticked
the Checkbox Option Deactivate Defense+ permanently (Requires a system restart).

jordanmoore
16.08.2011, 23:42
I un-installed DT Lite then restarted. Then I checked "Deactivate Defense+ permanently (Requires a system restart)" in COMODO, then restarted the computer.
Then I installed DT Lite again, choosing to install SPTD along with it. At the end of the setup I restarted the computer.

Upon system boot the computer told me it was configuring the new virtual drive - once that finished I opened up the DT Lite interface and went on to the "about" screen - this indicated that SPTD is installed (before disabling defense+ it indicated not installed).
I loaded the ISO into the virtual drive and went to install the application from the ISO but it still detects as a counterfeit DVD.

Terramex
17.08.2011, 10:45
I haven't explained in more detail before that the DT drive does
not use SPTD/Advanced Emulation - even when installed/active.
Only the SCSI drive provides advanced emulation. Even though those selectable emulation options (RMPS etc.)
are not required for mounted images (but only for burned discs): are they still greyed out ?

I understand it worked before, but which software are you trying to run ?

P.S.: if you want to cross-check with the version before
Download DAEMON Tools Lite 4.40.2 - FileHippo.com (http://www.filehippo.com/download_daemon_tools/9134/)
For diagnostically conclusive comparison also uninstall the current SPTD version
with the standalone Installer (http://duplexsecure.com/downloads) from Duplex Secure.

jordanmoore
17.08.2011, 13:04
They are still greyed out, yes.
I'm not sure what I need to do then, how would I go about creating a virtual SCSI drive?

As for the software, it's called Driving Test Success 2010, I bought it a while back but I've scratched it up so much that now the computer struggles to read it.
I guess that I could buy another one, but I'm saving every penny towards my biking lessons/tests/next years insurance at the moment - so I'd really love to get this working instead.

Cheers for the link - I'll try downloading some older versions to find the one that used to work for me.

jordanmoore
17.08.2011, 13:20
Just installed version 4.40.2.0131 with SPTD version 1.78.
I've now got the checkbox for "Advanced Emulation" back and all the other check boxes aren't greyed out anymore.

I've turned "Advanced Emulation" on and now my ISO is detecting that it's a real disk - so it's all working now.

Defense+ had to be disabled for this to work though.

Cheers for all your help everyone!

Terramex
17.08.2011, 13:48
Glad your main concern has been resolved.
But i'm still pretty stumped why SPTD didn't work properly with latest version.
The fact it's working now indicates the installation wasn't corrupted.
I was just about to ask you to try a manual uninstallation as described here:
Registry and SPTD problems | DAEMON Pro Help (http://daemonpro-help.com/en/problems_and_solutions/registry_and_sptd_problems.html)

They are still greyed out, yes.
I'm not sure what I need to do then, how would I go about creating a virtual SCSI drive?Do you remember if this was greyed out as well:
http://img231.imageshack.us/img231/9310/vscsi.th.png (http://imageshack.us/photo/my-http://img.forum.daemon-tools.cc/231/vscsi.png/)

...and good luck with your test :)

jordanmoore
17.08.2011, 13:52
I don't believe that option was greyed out, however I didn't specifically look in that region - I was using the drive automatically created for me on setup (perhaps that's what I was doing wrong?).

As for SPTD, that was definitely working because when I installed the current version of DT Lite, I never uninstalled SPTD. Consequently when I installed this version of DT Lite I'm using now it told me that SPTD was already installed and I didn't need to install it again. After that, advanced emulation was working without me needing to restart.

Thanks for wishing me luck with my test, I'll need it! :D
Now just if I could force this program to run windowed instead of full screen, nothing's working! - but nevermind, the program works now that's all that matters :)

Djahn
11.02.2012, 16:53
Hi there!
I know it is an old thread, but it is one of the first results!

It is for all Users of the Comodo Internet Security with Defense+!
I still had the same Problem and nohting helped. Then I figured out, that the Problem is the Comodo Defense+. To install SPTD correct, you have to deactivate your Defense+ completely temporarely:
Go to Defense+ -> Defense+ Settings -> General Settings
Here you have to check the "Deactivates the Defense+ permanently" -> reboot
After that, you should be able to get your SPTD to work. For me it worked, I hadn't to reinstall my DT.
After that you can enable the Defense+ again, also with the checked option!

It worked for me with the actual Version (5...) and SPTD 1.80!

saintrickm
22.04.2012, 08:08
Oky i gor 2 pc both is 64bit and both is running avg. but the on pc i just recently installd DT lite 4.41.3.0173 on both pc. non of the advanced boxes is selectable. i don't evan get a reboot request. pls help. sorry for my spelling.

Blazkowicz
26.04.2012, 15:06
Please install SPTD.