View Full Version : Error Need Help. "You already have maximum number of virtual DT Drives"

24.08.2011, 12:42
I've been using DT Lite since 2010. Recently , i used system
restore and my windows crashed , so i reinstalled a new fresh copy of windows , saving my old files. Now i want to mount my iso and i can't mount because DT Lite keeps Showing the
error taskbar "You already have maximum number of virtual DT Drives" when I did not mount any virtual drives. I had not used DT Lite Since this is a new fresh install. I need help.
I've been wasting too much time Please help me :icon_cry:

25.08.2011, 08:44
Specify your OS and DAEMON Tools version.

26.08.2011, 14:42
I'm having the same problem. When I updated to the latest version today(4.41.3) it wouldn't let me add more than two virtual drives. I tried an older version and now that one wouldn't let me either!

OS is XP and DTools Lite

(admittedly I was installing eastern asian language pack yesterday, so that could be why. I don't really think so though since I only added files to language and font folders, and it still worked afterwards. The problem only began after updating Dtools)

26.08.2011, 14:57
Actually nevermind. After reinstalling (with SPTD 1.78) and rebooting its working. It seems you can only add two SCSI and two DT drives, this is something that didn't show up in my older version at all. What's the difference between the two?

Thank you regardless

26.08.2011, 15:21
DT virtual drive uses embedded Virtual Bus driver which provides basic emulation only. It does not support any additional features like Advanced options which you can find in DTLite Preferences (Advanced section). SCSI virtual drive uses SPTD driver and provides extended emulation (e.g. protections).

27.03.2013, 12:23
Hello sway, could u please help me, i have the same problem as the other guy.

When i try "Add virtual drive" it comes up with a Error saying "You already have the maximum number of virtual drives."

Im running windows 7.

I treid to reinstall Deamon tools lite a couple of times and restartet my pc. Nothing happens.

Could you please help me??

27.03.2013, 13:27
Hello Friis,

please specify your DAEMON Tools Lite version and device type you try to add (DT or SCSI).
Did you use some old version before?

27.03.2013, 13:43
Hello Friis,

please specify your DAEMON Tools Lite version and device type you tried to add (DT or SCSI).

I upgraded to Pro Advanced (Trial) now but it still dont work.

The version is

My lite version was or something like that.

When i make a SCSI it just make a invail device.
I cant install the DT. I just fails.

27.03.2013, 15:38

Firstly, please, try to reinstall DaemonTools. In case, it won't help, please, look here for solution Your CD drive or DVD drive is missing or is not recognized by Windows or other programs (http://support.microsoft.com/kb/314060/en).