View Full Version : Virtual drives won't create?

19.11.2011, 17:45
I tried adding one and it just stays on the screen loading saying adding virtual device, Im o win7 (64). Getting really annoyed:( Any help appreciated

19.11.2011, 22:21
Please try this Microsoft FixIt solution & reboot
Your CD or DVD drive can't read or write media (http://support.microsoft.com/mats/cd_dvd_drive_problems/en-us)

Which DT version exactly are you using ?
Which security software(s) are installed ?

20.11.2011, 22:05
I think I have very similar problem. After instaling DAEMON tools and reboot, i was stuck with this little window saying adding virtual device, and after few minutes my system hanged. Im on win7 64, amd dual core. The exact same thing happened when trying to install alcohol. Does anybody know the solution?

21.11.2011, 01:25
Please answer the questions of Post #2.
Already tried the Microsoft FixIt ?

21.11.2011, 18:50
Tried microsoft fix it a few times yesterday and a while ago, and when i run the downloaded program some nasty error window pops up with some connection to server error kod 80072EFD. Disabled avast antivirus and same thing happens.

22.11.2011, 18:44
Disabling may not be enough to solve a known conflict between DT and avast.
This issue was already reported to Avast support and i can't tell if it's fixed yet, sorry.
You can still try the following:
If you have chosen to install the SPTD access layer (needed for DT's virtual SCSI drives) during setup, please download
the standalone installer (http://duplexsecure.com/downloads) from Duplex Secure and use it to uninstall that SPTD driver, reboot.
Now try to start DAEMON Tools and add a "DT" drive - not a "SCSI" drive.
The "DT" drive doesn't need the SPTD driver and hopefully doesn't conflict with avast.

Regarding that 80072EFD error you've quoted: do you have some other than the Windows firewall running ?

And finally, please download this tool: http://www.bustrace.com/downloads/devfilter.exe
Run it, highlight your optical drive on the left, then highlight upper/lower filters on the right.
Which filters are installed on your system ?

20.01.2012, 21:08
Guys I tried this and it worked fine, give it a shot it may work for you as well

Uninstall DAEMON Tools. Then find "C:\Windows\System32\DriverStore\INFCACHE.1" file (this file has different path on Win XP) and move this file somewhere or rename it.Then restart your system, install DAEMON Tools again and check the problem with virtual devices.

The above worked for me. If not you can also try this

Or you may need to check your system integrity:Run CMD.exe as administrator and start the following command:sfc.exe /scannowThis command will check integrity of system files and may ask you to insert installation DVD disc to fix some files.