View Full Version : Installing SPTD crashes my system, nothing helps.

28.02.2012, 18:35
Hello, so i know that there are countless threads with the same title and the same subject, but for the love of christ, i've been searching for a solution for 3 days now and i didn't find any solution that helped me!

So about 2 weeks ago, i've began receiving this error saying something like "Daemon tools requires Win2000 and above with SPTD", and i just ignored it because i wasn't really using Daemon tools, until recently when i needed to mount an ISO, i tried to open DT but it gave me the said error, so i decided to reinstall it, and after the SPTD installation, it prompted me to reboot my computer.
So i did, and at the Windows loading screen, i got a BSOD.
At first, i used the system restore point created by the SPTD installation to revert my system a few times and try to install different versions of SPTD, all of them led me to the same issue.
Eventually, i tried to install DT again, and after DT asked me to reboot, i entered safe mode and deleted "sptd.sys" from c:\windows\system32\drivers, so i could boot my PC normally again, and DT remained installed on my system (because i didn't use restore point like before), anyway, DT opened normally, but when i tried to create a virtual device (by default, there were none active) and it gave me an error code 1500, and the only other option in the "Virtual devices" menu is to install an SCSI driver (SPTD, that is.) which would cause my system to BSOD upon reboot.
In addition, i tried removing the HKLM\System\CurrentControlSet\Servies\sptd registry key, but it tells me "Cannot delete SPTD, error while deleting file" and it gives me an error when i try to change permissions, aswell, so i am not sure if deleting it would help or not.
Also, i couldn't get any other virtual disc software to work, either, because most of them require SPTD (BSOD) and those that don't require SPTD (Such as MagicDisc and Virtual Clonedrive) have their own errors which prevent them from working.
I wonder, is my system rejecting Virtual Device software or something?
Anyway, sorry for the massive wall of text, i just really need help with this problem, and i'm not sure where else to go anymore.
Additional details:
OS: Win7 Ultimate Edition 32bit
DTLite Version: 4.45.3 and SPTD Version: 1.80 (although this issue occurs with any other versions and combination of versions of the above).
I am not running any Antivirus software.
I did not update my Windows for months, although i did have an automated file check recently.
Thanks in advance!

28.02.2012, 19:46
Please post latest minidump available at c:\windows\minidump.

Do you have a HP notebook?

28.02.2012, 21:34
Please post latest minidump available at c:\windows\minidump.

Do you have a HP notebook?

Wait, do i post the minidump file itself or do i open it and post the contents here? i have no idea how to open .dmp files.

29.02.2012, 10:44
Post the minidump file please.

29.02.2012, 15:51
Post the minidump file please.

It tells me "invalid file" when i try to upload the file to the attachment manager, same thing when i try to upload the mediafire link.

However, here's the direct mediafire link.


29.02.2012, 16:44
It is crashing in nvlddmkm.sys which is part of NVIDIA drivers. Try to update all of your NVIDIA drivers (chipset, graphic card etc.).