PDA

View Full Version : ? D-Tools 3.46 Uninstallation Problem - Missing DisplayName in Add/Remove



Synetech
19.06.2004, 03:04
Operating System: Windows XP
Burning Software: n/a
Anti-virus Software: n/a
DAEMON Tools Version: 3.46

Hi,

I just successfully removed D-Tools 3.42, then installed D-Tools 3.46. D-Tools seems to work fine, but there's a problem with the uninstallation information. If I bring up Add/Remove Programs, then there is no D-Tools entry. Instead, there is an entry with a blank name.

I fired up Regedit, and navigated to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{56CA5D3B-3002-4E7B-90FE-071D8FDF3814}

I modified DisplayName, changing " " with "Daemon Tools". I then immediately refreshed and found that "Daemon Tools" had suddenly been replaced with " ". I tried this a few times. I then tried renaming DisplayName to 1DisplayName and changing the blank to "Daemon Tools" again and it stayed properly. I then renamed 1DisplayName it to DisplayNam and it stayed properly. However if I renamed DisplayNam DisplayName, it suddenly changed to " " again.

Furstrated, I tried renaming {56CA5D3B-3002-4E7B-90FE-071D8FDF3814} to {56CA5D3B-3002-4E7B-90FE-071D8FDF3815} (I changed the last digit). I then changed DisplayName from " " to "Daemon Tools" and it stayed properly. I then changed the GUID back to what it should be and it again reverted to " ". I then tried something different. I changed DisplayName to "123" and it suddenly changed to " ". I then changed it to "123456789012345678901234567890" which changed to " ", and finally, "1" changed to " ", and "" [changed] to "".

So, where am I now? I find that for some reason, someone keeps AUTOMATICALLY changing "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Uninstall\{56CA5D3B-3002-4E7B-90FE-071D8FDF3814}\DisplayName" so that all of the characters are replaced with spaces.

I have NO idea what/who could be doing this. D-Tools is NOT running, and there are no unknown process running. I have just today updated Windows with all availabled updates from windowsupdate.com. Other than that, none of the other changes could have anything to do with this.


What is going on? Could MS possibly have flagged D-Tools somehow? How can I fix this? Is anyone else having this problem? Is there anyone who has XP SP1 installed with all updates, running D-Tools 3.46 and finding the proper entry in Add/Remove?

Oh, and for the record, 3.42 did NOT have this problem at all (then again, there's quite a few changes since then).


:? :? :? :? :?


Thanks in advance.

MisterEd
19.06.2004, 10:27
Operating System: Win XP Pro
Burning Software: Nero
Anti-virus Software: Norton
DAEMON Tools Version: 3.46

same for me, but is this a problem?

i think this is a "new" feature and normal behaviour of DT, just to prevent an easy blacklist via "let me look in the add/remove section and if i find daemon tools then i will not work".

Copytrooper
19.06.2004, 10:57
Actually there should be a DAEMON Tools entry in Add/Remove section (aka control panel -> software) - strange ...

Synetech
19.06.2004, 17:38
Right, that's what I thought. I mean there really isn't a need to protect it since it's not a "bad" program in it's own rightfor example, MS keeps putting out new versions of its free PSDK a few times a year, so I do not like to waste CDs on it, instead I just mount it and install from that.

Besides, like I said, there were no unusal processes running INCLUDING D-ToolsI suppose the driver could have been doing it, but that's really out there.


Copytrooper, do you have a DAEMON Tools entry?

Copytrooper
19.06.2004, 17:53
Copytrooper, do you have a DAEMON Tools entry?
Yes

Synetech
19.06.2004, 22:16
Is it labelled properly? Is it 3.46? (Unfortunately I think the answers are yes.)

Copytrooper
19.06.2004, 22:43
Yet another yes :mrgreen:

MisterEd
19.06.2004, 23:16
some more details...

if you install dt 3.46, there should be an entry in the add/remove section displayed as "daemon tools", but if you look into the registry, the display name is set to one blank.

if you now want to change the key display name e.g. to "daemon tools 3.46", as i tried with win98, but not yet with xp, the entry is also displayed with one blank. i was not able to reset the settings.

i noticed this behaviour first with dt 3.46.

Development
24.06.2004, 21:55
Driver keeps this enrty protected - you cannot see it by usual means.