View Full Version : Cannot assign a drive letter / Virtual drive shows up as "other device"

07.07.2004, 22:12
Operating System: Windows XP Pro, all updates, on a domain
Burning Software: none
Anti-virus Software: Symantec Corporate Edition 8.1
DAEMON Tools Version: 3.46

During install, initially the virtual scsi controller cannot find the driver (windows asks where it is, can't find it, and fails), but then apparently the D-Tools installer recovers and forces the correct driver to be installed, because when it's all said and done I DO have a SCSI controller installed. I'm then asked to reboot.

But after rebooting, the virtual DVD drive is created and the driver is not being recognized as an actual device -- it shows up under "other devices" in device manager, and does not show up under Disk Management either -- and when I try to assign a drive letter through D-Tools, it does not save the setting. So I have a virtual DVD device with no drive letter that I can't use for anything because Windows doesn't think it really exists.

I am a local administrator with all normal local computer admin permissions, but the computer is part of a domain. Could that cause any problems? I also had an old version of D-Tools on here a long time ago, and uninstalled it, could that have buggered something up?

If none of those is the problem, what am I missing?

07.07.2004, 22:54
Well, after looking around a bit I managed to fix this. I'm leaving the thread up so hopefully anybody searching for help with their problem will either find the solution here or elsewhere. Here was my solution:

Open Device manager, open up "Other Devices", select the virtual drive.
Right click on the device - update driver.
"Advanced" / Do not search, I will choose the driver.
Select device type CD/DVD ROM Drive

It will come back and say "No compatible drivers found". Well, DUH, that's why I'm doing this manually! Stupid MS! :D

OK, now click "Have Disk". Browse to "C:\Windows\INF\cdrom.inf, select it.
It will churn for a bit and then give you a LONG list of compatible device drivers. Choose "CD-ROM Drive". (The force CDDA accurate option might also work -- didn't try it. You don't need any of the IMAPI driver versions because this is not a burner.)

Once this is done, you should have a "real" drive that will show up under device manager in the proper spot, and under disk management as well.

Not sure but you will probably have to do this with all four devices if you have more than one virtual device -- and may have to do this every time you change the number of devices. Hopefully I'm wrong here tho...