PDA

View Full Version : Problem: Unable to mount image. Unable to open file in kernel mode!!!



Baylz88
29.07.2004, 13:16
Hey i have been unsing Daemon tools for a while now and everything has always worked ace!! :D but the other day i unmounted an image and turned of the PC without an image mounted (sumfin i usually dont do!!) and when i turned my PC back on and tried to mount an image it displays the alert "Unable to mount image. Unable to open file in kernel mode."

I have re-installed the latest version of daemon-tools and tried every troubleshooter but it still wont work :evil:

Does anyone no the solution? plz reply im isolated from mounting images and it has been a week already :evil:

lx_uk
30.07.2004, 07:52
Wrong forum... :)

jprc
02.09.2004, 12:56
Operating System: WXPsr2
Burning Software: Blinwrite5
Anti-virus Software: NAV2004
DAEMON Tools Version: 3.47

I have the same problem, and can not mount my "Call of Duty" image, done from original CDs, with my copy of Blindwrite5 (with files B5I and B5T). I get this error message.
This thread is the ONLY ONE with the error message "unable to mount image. Unable to open file in kernel mode".
Unfortunately, the answer to the 1st thread answer nothing and is more destructive than positive...
"Wrong Forum".
Thank you. But where is the RIGHT FORUM then??
My search found nothing regarding this topic, but this thread, meaning that the gentleman who posted the 1st question just gave up!

1- Where is "the right forum" for this kind of problem?
2- Why this problem?

Copytrooper
02.09.2004, 13:12
1. The thread was moved, it was in wrong forum before - this is the correct forum ;),
2. This problem maybe caused by strange chars in name, some antivirus, or filter driver.

jprc
03.09.2004, 06:53
Thank you for your suggestions! What I saw after rushing back to my computers (the same problem on 3 different computers!):
1- the problem is not from the file name: "CoD-FR.B5I" and "CoD-FR.B5T", using the simplest format available: 8.3, with regular ASCII codes
2- After rebooting in safe mode - no networking drivers-, same problem: it is then not from my antivirus software (registered Norton AV 2004). Not from filters also as one of the 3 computers has been received 2 days ago from Dell, files unchanged from basic Windows load by Dell, the second one is managed by a colleague, and the 3rd one is mine. What are then the probability to have a "filter" installed on all 3 computers, and in the same time having all other people using Daemon without trouble? it is 0
3- Thinking about having an B5T/B5I corrupted file, I burned 2 CDs. Installation of "Call of Duty" was fine, using those CDs. Exit then the "corrupted image"
4- I recreated a new image of "Call of Duty", using my registered Blindwrite 5.2.3 (the latest). Same problem: Daemon tool send the same error message.
5- I created then a copy of my original "Call of Duty" CDs, using CLoneCD (with a Cue sheet, i.e. creating an additionnal *.cue file), and Daemon mounted the CD without problem!!
6- of course, I tried with other images created with BlindWrite and all are working fine, only "Call of Duty" does the problem

Conclusions, choose the one you prefer:
1- Daemon tool is not able to handle 100% of Blindwrite images
2- Blindwrite images are not stable (or consistent) for being red by Daemon always in the same way (variable image?)
3- Activision's Call of Duty CDs (French 1.1 version) are with a special protection not correctly handled by BlindWrite, thus changing slightly the content of the image, thus destabilizing Daemon
4- I dont' know.

Any other ideas??... :roll:

Copytrooper
03.09.2004, 08:23
Please send the b5t files to support@daemon-tools.cc for analysis (RAR'ed).

jprc
03.09.2004, 15:19
I am very sorry not to be able to send you anything. If you record IPs, so then my IP is: DELETED
It means than I am in Mozambique (Maputo), where I work (and live, no choice...).
It means also that my internet connection is very slow: it is a dial-up, at 28.8 (when extremely lucky), with numerous time out and other nice cuts you would expect when you live in a poor poor country... Sending one of the 2 images COD-FR.B5I (802.201 and 781.462KB) would take days!!!
It is also why I like Daemon, because I can let home (France) my precious original CDs, with no risk of having them stolen, or exploding (Maputo is hot, laptops are getting hot quickly, and having a CD continuously spinning in your drive is perfect for ... the maintenance service and/or the trash bin). It actually happened already...
However, if you can tell me if there is anything I can do (ex: send the header of the file by trunkating its start, I should be able to do this with WinHex), or run a test from a (small) program I can download somewhere, I would be more than happy to assist.
Anyway, thank you for the suggestion, it was nice of you.

Copytrooper
03.09.2004, 15:22
No, you should just send the TOC files (b5t) around 1kB size each, not the whole image (b5i) ;)

jprc
03.09.2004, 19:39
Oups! It makes a huge difference! I have just sent the 2 files (2 CDs for "Call of Duty" v1.1 FR to the support.
subject: CoD-FR.B5T files, for error -unable to open the file in kernel mode-
From now on, I let the pro on the job...

Andareed
04.09.2004, 11:44
COD-FR.B5T: The main (large) BWI should be called COD1.B5I

COD-FR.B5T: The main (large) BWI should be called CoD2.B5I

Because of the nature of B5T files, you cannot easily rename the B5I files. You can generally use a hex editor (or probably notepad) on the B5I files to see what the correct name of the B5I should be.

jprc
04.09.2004, 18:22
Exact! It works now! :D
I then summarize the problem:
If you get "Unable to mount file in kernel mode" message AND use Blindwrite 5, then it is because you have renamed the 2 Blindwrite 5 files produced for creating an image (extension B5T and B5I). Blindwrite5 assign a name and record it INSIDE the file itself when you create the image! :evil:
Renaming the files back to the original name solves the problem!
For knowing what is the original name, open xxx.B5T file with Notepad. It will give something like:
BWT5 STREAM SIGN     М)NЕ?ПgЪdw
ЁЯ\ь[К^x ASUS CRW-4824AH 0.89WI030922 COD1 >  Ä [/b

In this example, the original name is: COD1
The 2 files produced for an image must be renamed (ex, COD1-FR.B5T to COD1.B5T, and COD1-FR.B5I to COD1.B5I)
And Daemon will work fine.

Conclusion:
NEVER EVER RENAME A BLINDWRITE FILE AFTER HAVING CREATED YOUR IMAGE !!!

Thank you to the Daemon team, they were efficient!!
(perhaps you should send me your CVs... would you like to work in poor countries?... :wink: )

roxeri
05.12.2005, 10:39
No, that's absolutely wrong in general case!
It doesn't depend on machine, soft, AND .mdf/.mds file or else!!
I'm sure! I fucked up of this error message! Same image files work at home & don't work in computer class (on 30 machines of 50!).
It's a bug of daemon tools, developers don't want to see it! It may be uncompability, wrong requests or...
It ALWAYS works through the GUI, but command line sometimes generates the error!

Underheaven
05.12.2005, 16:19
Roxeri, you need to use quotes when mounting a file from the command line. And try to avoid using long filenames if possible.

What version of DAEMON Tools are you using?