PDA

View Full Version : System Hard Lock When Accessing Image



Opie
05.08.2004, 17:52
Operating System: XP PRO SP1
Burning Software: none
Anti-virus Software: none
DAEMON Tools Version: 3.46

In the last week I've switched from a single IDE drive to 2 fast SATA drives which I configured into a RAID 0. My mobo, an Asus P4G8X Dlx, has onboard SATA support via a Silicon Image 3112A controller, and I'm using the latest drivers from SI. Got em installed, fresh XP Pro, updated Direct X, video drivers, etc, then finally DT 3.46. I proceeded to install BF 1942 from my cds, and just yesterday Doom 3. I mounted up my trusty images of BF disc 2 & Doom disc 1.

BF starts fine. I can join a server play through the map, but when it comes time to map change, which means the CD is accessed, my system hard locks. I have to manually powerdown.

Doom 3 starts up fine.....the first time loading after a fresh boot into windows. If I make some config changes, exit & try to reenter the game, my system hard locks at the splash screen. I have to manually power down.

I havent changed any ASPI or ATAPI drivers.

I really like DT for the convenience, and the prospect of having to run without it really bums me out. The other thing I dont understand is why I get a hard lock on what seems like every other disc access.

Thanks in advance for any help.

Dekai
17.08.2004, 19:16
Operating System: Windows XP SP2
Burning Software: Nero 6 Ultra
Anti-virus Software: None
DAEMON Tools Version: 3.29-3.46 tested

I have the Exact same Error When mounting an image. Sometimes I can mount the image first time no problem, but if it does succeed it will hard lock my system if i mount a new image. I have tried versions 3.29 and Versions 3.46.

Hardware if this helps is as follows

Abit IC7 Max 3 Motherboard
P4 2.4c @3.0
2x256 PC3200
Maxtor Diamond Plus 9 160GB HDD

Dekai
18.08.2004, 09:20
Ok I do not think this is an isue with Daemon Tools. Multiple Cd games hard lock my system as well e.i. Knight of the Old Replublic. It install first CD, but when inserting Second Cd system Hard locks. Opie I suggest and see if this si the case for you. Try installing a Multiple Cd application (using a REAL Cd and REAL CD/DVD-Rom).
Personally I can't find out how to fix this. So I backed up my files, and I am about to format my HDD and doa fresh install of the OS and all Drivers.

Copytrooper
18.08.2004, 09:47
The issue you describe is in fact SecuROM bug leading to system hang. Some programs trigger this bug, e.g. AnyDVD.
I don't think this is related to Opie's problem.

ghosted
20.08.2004, 19:19
Operating System: Windows XP SP2
Burning Software: Alcohol 120% 1.9.2.1705
Anti-virus Software: Symantec AntiVirus 9.0.1
DAEMON Tools Version: None

My problem was solved when I switched to Alcohol 120% 1.9.2.1705. If you try it, make sure you do an expert installation and change the name of the alcohol bus and scsi driver to help with the blacklist. I don't know what's wrong with Daemon-Tools, it just doesn't work for me.

Dekai
02.09.2004, 15:20
UPDATE

I found out what was causing my issue for the hard lock ups. It seems that Ahead softwares InCD conflicts with Daemons tools plus other various Virtual Drives and Regualr Media drives with ANY Protection Drivers installed. e.i. SafeDisc, SecuROM, and StarForce. I have tested this thoroughly, and if anyone wants the strain, please try it as well to confirm if this is your problem as well. All i had to do to make it fully functional was Uninstall Ahead InCD from Add/Remove Programs and then everything worked fine again.

If any Beta Tester, Moderators, or Admins want to confirm this please do. And if this is a proven scenario, please make a new thread about it in the proper area alerting others to this issue, Thank You.

Not a Daemon Tools Problem, but well worth knowing for anyone else who may encounter this

Copytrooper
02.09.2004, 15:33
Check with v3.47 please, it should fix the InCD issue.

slimon
02.09.2004, 23:27
Operating System: Windows xp
Burning Software: Alcohol 120%
Anti-virus Software: none
DAEMON Tools Version: 3.46

My computer Locks up when ever i try to play a game using and image.. The only way i can play any game is loading and image then Exiting Daemon tools and removing all emulation. What's wrong.. and will 3.47 fix this problem? also will it fix the blacklisting problem as well?