View Full Version : Emulation doesn't work

Bodo Bach
18.09.2004, 16:32
Hey Guys,
first wanna say 'Hello' to everybody as I'm new to this Forum.
I'm writing here because I experienced a major problem using DT which I can't solve. I've have a NEC 3500 as primary master and Toshiba 1612 as primary slave. HD is connected to SATA.
Now when I burned a SD2/3 game (Painkiller, Delta Force Black Hawk Down) with Alcohol (and the appropriate profile) to CD and wanna start it (with Daemon Tools safedisc emulation turned on), Daemon Tools won't interfere and emulate the copy protection.
Thus the game won't start. Tried to install ASPI 4.60 properly but still doesn't work.
Any solutions on this problem?


18.09.2004, 17:20
In order to use SD2/3 emulation you've to use emulation for image/backup creation, so Daemon Tools/Alcohol knows which weak sectors are to emulate (check manual for fast dump feature). The problem is, that SD3 uses diffrent weak sectors and different way to check them, so the emulation of newest SD versions does not work anymore. We're working on it.

Bodo Bach
18.09.2004, 18:15
So just to check if I got it right:
Til now I did my backups of SD2 by reading with DiscDump and writing with Fireburner (and an Liteon 32125W). The backups didn't need an emulation.
As I wanted to have a DVD-Writer and the old Liteon burner can't really cope with SD3 I now wanted to emulate the protection, but still burn it to CD (my HD is rather small and I don't have the space to put the images on it). So I thought I could read and write the protected CD with Alcohol (which would then be a 1:1 copy) and then only turn on the protection emulation. But this actually doesn't work (whether it's SD2 or 3; let's take the SD2 for better understanding).
So you say I would then have to install the game, run it and then use the fastdump feature do make the backup working with Daemon Tools? Is this the only way? I would prefer something less time demanding!?!
Would it be possible to make an image with Alc and write it to CD as is, so that I have the mdf-file on my cd, and then mount it from this cd to daemon tools and run it?

18.09.2004, 18:31
If you create an image with Alcohol and its bad sector emulation (use it like fast dump feature) you get the same ;)
You can create an image an write it to disc (if it fits), then mount it. It should work.
As I mentioned we're working on it ...

Bodo Bach
21.09.2004, 14:25
Hi, it's me again. Just tried it with Doom 3, which is SD 3.2

Made two copies:

1. Read with Alcohol, burned with Alcohol (so the copy is now a 1:1 from the 1st Disc)

2. Read with Alcohol, burned the image as is with Nero (means I have the mdf + mds files on the disc).

Now the thing is after installation I mounted the Image from 2. to Daemon tools and it works like a charm. So Daemon CAN emulate the protection.
But when I try to play from the 1. disc, with safedisc emu turned on, it won't work. So the problem seems to be that Daemon doesn't interfere when the Game checks the Protection on the disc.

Any solutions on this?


21.09.2004, 17:33
There's no emulation from image (needed), the problem with SD2/3 is, that the weak sectors can not be written perfectly. This is were Daemon Tools emulation should work, but newest SD versions use other check and weak sectors so it doesn't work atm.

Bodo Bach
21.09.2004, 17:53
Bump, how stupid I am! :x When I think it over i could beat myself. As long as the image is only written to HD the weak sectors are perfect. So the image must be perfect when mounted, too. Problem is the writing. Only there DT has to emulate.

Thank you Copytrooper for bringing me inspiration and showing me the way :lol: :arrow: