View Full Version : daemon.msi problems

11.11.2002, 18:35
When i go to install Daemon Tools it tells me that it can't find my daemon.msi file, so i find it for the stupid cpu and it tells me that it is bad or can't execute. What do i do, im running Xp.


11.11.2002, 20:27
Set full permissions to directoty where you have this file.

12.11.2002, 01:02
it says that the file daemon.msi is not a vaid instalation package or something could a previous version be my problem. I had a older version installed about a year ago but uninstalled it, 8 months ago

12.11.2002, 01:05
How do you set full permision to a folder?

12.11.2002, 06:13
I had this problem, I had to take out all references to daemon tools from my registry. I cannot check or change the properties of my cd drives now, but it may or may not have caused it.

12.11.2002, 18:14
how did you remove it from your registry???

12.11.2002, 21:26
I searched for the word daemon with a regestry searcher (start->run->regedit or something like that for a windows one) and used my judgement on what had to go. I exported the registry parts before I deleted them to safety's sake, but there might be a safer, better and faster way to do this so ask around.

12.11.2002, 21:36
If setup cannot see daemon.msi then don't even try to do something with your registry - better watch where you placed daemon.msi and what permisions you set to this directory. I wonder what you guys do with your OS? I had did hundreds of XP installations and never experienced such problems... After default XP setup daemon can be installed from any directory.

13.11.2002, 07:45
Just because this seems to be a major problem, I will revive my DaemonZap program. It will be able to fully clean D-Tools from the installer database and from the registry. I don't know when this tool will be released.

19.11.2002, 21:18
I have the same problem

20.11.2002, 00:40
The solution to your problem is already given in this and many-many other threads - make FULL access to everyone to directorory where you extracted daemon installation files.

20.11.2002, 11:03
If D-Tools is unpacked to the pre-set dir (user\temp) everything should work fine (if nobody restricted access manually).

BTW, could you please give the EXACT error message you got?

25.11.2002, 00:08
I have this problem too, basically it arose when i used some registry cleaner and constantly received the language support error. Being unable to use the uninstall prog, i manually deleted it. After that, whenever i tried to install i would get the daemon.msi problem. It would prompt me for the daemon.msi file, and when cancelled it would say something to the extent that the programme cannot be deleted due to a technical problem.

Has anyone managed to solve this problem before? I tried handling the registry manually but to no success.

25.11.2002, 23:00
You need the daemon.msi of the DAEMON Tools version you have installed (NO other version will work - you need exactly that daemon.msi)!! When you're told that Windows cannot find it during uninstall you need to manually enter the path to that daemon.msi and then press OK.

If you don't have the installed D-Tools version anymore please post your version number here and I'll mail it to you (or download it from our main page if it's not older than 3.20)!