PDA

View Full Version : Installing D-Tools 3.47 makes my HD disappear!



cherrio
22.09.2004, 11:44
Operating System: Windows XP (SP2)
Burning Software: Nero (6.3.20), CloneCD (4.2.0.2)
Anti-virus Software: AVG 6
DAEMON Tools Version: 3.33


Had a lot of problems in the last 24 hours with D-Tools.

Basic Setup
C:\ WD 72G - SATA (Boot HD)
D:\ WD 120G - IDE
E:\ Maxtor 160G - IDE

- D-tools was originally installed on D:\
- tried installing 3.47, had problems.
- restarted computer and my d:\ drive had disappeared! (Both c:\ and e:\ still existed)
- Was not able to uninstall D-Tools as it was installed on the D:\ drive!
- Got it working again, by installing an old version, that was able to 'repair' the old install.
- Deleted all references (that I could) to "d347bus" and "d347prt" in regedit
- Installing 3.33 caused a BSOD, but fixed that by removing the Starforce driver

3.33 is now working on my computer and d:\ drive is as it should be.

- When I try and install 3.47 now I get an error
- - with "d347bus" and "d347prt" defaults set
- - - error: Some drive has invalid name or conflicts...
- - with alternative driver names set
- - - Installs, but D drive disappears.

- Regedit still contains references to "d347bus" and "d347prt", but when I try delete them I get an error message, "Cannot delete x".

Any ideas?

Copytrooper
22.09.2004, 11:56
Check thread about error 25002 in common problems and solutions forum.
Note that the drive letter assignment is made by Windows, so if Daemon Tools virtual devices get a drive letter that was assigned to your hdd, you probably face the Windows bug, where a drive letter is assigned over already existing mapping.

cherrio
22.09.2004, 12:49
thanks for the reply Copytrooper.

I did indeed search the common questions and solutions forum. With its help I was able to get things mostly working again.

But, after following the Error 25002, or how to remove Daemon drivers (http://www.daemon-tools.cc/dtcc/portal/viewtopic.php?t=2287) instructions and deleting all references that I could to d347bus. I am still unable to,

- Install 3.47 (get error messge described in 1st post)
- delete all references to d347bus / d347prt.

Checking device manager shows no signs of D-Tools drives or a reference to PnP. Is there another way of deleting the d347bus keys from HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es ? As I mentioned I get an error message when I try it now.

Copytrooper
22.09.2004, 13:17
Check with regedt32 if you've permissions needed.

cherrio
23.09.2004, 10:17
thanks for the tip.

I did that and was indeed able to delete the last references.

I then restarted and tried reinstalling, eventually was able to install* but my HD disappeared. D-Tools had made a CD drive labled D.

I rename D-Tools CD drive to T and restarted. My HD did not come back (D-Tools drive remained labled T). I uninstalled D-Tools and HD came back. I am able to get 3.33 working (and my HD stays in place).


* during the install I got the error reporting a drive name clash, in order to get it to work I called the drivers "ad347bus" and not the defaul d347bus.