PDA

View Full Version : DAEMON Tools Pro driver error: 8



TraumaDoc
15.04.2015, 03:25
Hi

Using Windows 7 Ultimate SP1 64-Bit, English, with Chinese PRC Locale
Using Daemon Tools Ultra 3.0.0.0310

I am now getting an error (error code 8) as in the title of my post:

DAEMON Tools Pro driver error: 8

I can no longer mount any images of any type. I can no longer see the virtual CD-ROM drive that was usually there in Windows Explorer as a drive letter. It isn't there as a device in device manager.

I have removed the program, reinstalled, tried DTools Lite as well. I have installed SPTD 1.87x64, but when I reboot it still seems it isn't there. If I run the SPTD install again, it shows that it was never installed.

In the older versions of DTools Lite I used to use before you had the option to create a new virtual mount point, so it would create a new drive letter, but that option isn't here in Ultra.

If I manually mount, drag and drop, use image manager, widget, etc. I get error code 8 or a message that says "Insufficient resources to create target connection"

I have also disabled driver enforcement in Windows start-up and that doesn't help

So, I can't mount any images and it appears that the virtual mount point created in the install process is gone and I can't get it to reappear or reinstall with DTools install or SPTD install.

I'm sure something was probably just deleted from the registry and the keys are gone to allow the mount point creation or driver or something, but I can't pinpoint it.

Suggestions?

SUPPORT1
15.04.2015, 13:42
Hello,

"Engine Error code: 8" this error means that some software (usually security software - antivirus, firewall, etc.) block DAEMON Tools work.
Stop your antivirus protection.
Please check if you are able to assign drive letter via standard Windows tools.
Right-click on MyComputer -> Manage -> Disk Management -> right-click on the drive which has no drive letter in the right part of the window and click "Change Drive Letter and Paths..." menu item to change/assign drive letter.

TraumaDoc
15.04.2015, 17:24
Well, there are no software apps like virus or firewalls going on here. There IS NO drive letter for dtools scsi drives or any dvd/cdroms drives for that matter. Not hidden, not there.

Problem solved because I removed my dvdrom and replaced with an bay that allows inserting another sata notebook drive in the slot.

I had to reinstall (physically) my dvdrom, choose default cdrom.sys drivers and then dtools could mount and make drive letters on it's own.

It makes no sense to me that it is a necessity to have a physical cd/dvd drive installed to use DTools mounting... doesn't it defeat the purpose?

So, while I have solved the problem on my own, your answer doesn't suggest what is going on otherwise. I must keep a DVD-CD installed on my system to allow DTools to work? Removing it and leaving the bay open will do what to DTOols ? Inserting and keeping an sata removable tray in the cd-bay will do what.

Make no sense. Really, it seems to be a configuration of Windows or registry since this is a new problem and DToools worked in the past with no physical dvdrom ....

Confusing, annoying, fixed on my own, but still need an actual explanation of the root cause and how it can be avoided. I don't use physical dvd/cd anymore, just use that bay for a caddy that allows inserting a 3rd notebook drive on my system.

Rattling on...

Thanks for the suggestions.