View Full Version : Error when trying to run installer from mounted .ISO file

09.07.2015, 16:28
I am using a paid license of Daemon Tools Lite v. 10.1 on Windows 7 Professional with Service Pack 1. My issue is that I can successfully mount an .ISO file as a virtual drive; however, when I attempt to run an installer such as an .EXE or an .MSI which is contained in the .ISO, I get an error message reading "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." This appears whether the .ISO file is mounted from my local drive or over the network, and whether or not I run the installer as Administrator.

I tried emailing Disc-Soft tech support and got a (prompt) reply advising me to disable my antivirus software or "change settings in your antivirus to allow that software to run." I don't have issues running .EXE or .MSI installers from a physical drive, so I'm not convinced that's the issue. If anyone either knows otherwise, and can elaborate on the specific antivirus settings to change (we use Symantec Endpoint Protection v 12.1.5), or knows of another solution or workaround, I would be most grateful.

10.07.2015, 09:52
That applies to every ISO ?

Have you tried the Microsoft Resolution suggestions yet ?

P.S.: with this handy tweaker you can easily take ownership of files/folders/drives - if required
Ultimate Windows Tweaker v 2.2, a Tweak UI for Windows 7 & Vista (http://www.thewindowsclub.com/ultimate-windows-tweaker-v2-a-tweak-ui-for-windows-7-vista)