View Full Version : Error message - DMT is installed but locked

21.10.2004, 17:05
Operating System: win xp sp2
Burning Software: nero bundled
Anti-virus Software: avg 6.0.778
DAEMON Tools Version: 3.46

So - running the program - doesnt matter if image is mounted or not - i get the following message window:
Daemon Tools is installed but locked! Please unlock Daemon Tools and restart Application.

Note that both Lock DLL and Autolock options are unchecked, as i understand that means off. The image unmounts, mounts correctly and the image itself is unlocked by my humble understandigs - i can move, delete and so on.
The same program worked good yesterday, but starting the comp today showd daemon.dll error - i repaired installation, then got the message. Then removed DT completly and tried again - same. Of course after reinstalling DT. Other aps, images work.

Please help - my brain is stuck.

All the best - so far DT has been a very big help.
Priit aka okaloka, Estonia, Tallinn

21.10.2004, 19:03
which game you try to start? Maybe Knights of Honor?

22.10.2004, 09:01
Exatly. Knights of honour....

22.10.2004, 20:40
so - is there a tip? or is this only knights of honour problem?

22.10.2004, 20:50
Due to a "bug" in KoH's copy protection daemon.dll in Windows folder is renamed to daemon.bak - check if that happend, and if so rename it back to .dll.

24.10.2004, 17:00
Yap, thats what its doing. Each time i start the bloody thing, it renames the dll. So i understand it is not possible to run the program any more? Or can i block it from accessing the dll somehow? Lock dll didnt do it.

25.10.2004, 08:50
You can prevent it accessing the daemon.dll by using NTFS permissions, but the game won't run then (it needs super user privileges for it's kernel-mode copy protection modules).

Maybe it could be tricked somehow by running in a chroot-like enviroment, making the game believe it has super user rights?
In practise this would be very difficult, maybe even requiring a full PC emulator.
Since this method also bypasses the copy protection as a side effect I fear it would be just as illegal as just downloading a patch.

I'm afraid your only practical solutions are to play from your original CDs and wait for updated Daemon Tools or use a patched version of the game (the latter is illegal at least in the USA, Australia, UK, Germany and Spain, not recommended!).


Return the game to the store and explain that you want your money back since the game disables other software on your computer without your permission.
Be ready for a fierce struggle returning an opened game (funny BTW, since they presume you made a copy of it, why the heavy copy protection at the first place?)

I have done this twice (with Red Alert 2 and Diablo 2) and it was like banging my head to concrete floor - all day.

25.10.2004, 11:41
thank you all for help, for now ill just put the problem aside then. the stores here also refuse to take back opened products, but they also refuse to compensate broken cds caused by hardware malfunction. I went trough a complicated conflict with cd reader braking my cd, but guess who has more money to go trough the legal system ... me or the wholesale company. so from there on i try to use backup copys instead - my money is in a very unstable enviroment - when it is converted to a piece of fragile plastic that is turning in extreme speeds in a chinese cheesmaker. :)

thak you once more, nice to find that there are helpful people around.

28.11.2004, 18:05
Operating System: Windows XP service pack 2
Burning Software: nero 6
Anti-virus Software: mcafee
DAEMON Tools Version: 3.47

I had that problem too, but I deleted daemon.bak, and I deleted daemon tools also. I can't install it, cause it is somehow still running...

28.11.2004, 23:09
who told you to simple delete daemon tools?

Please describe what you did more exactly

29.11.2004, 15:27
If you just deleted the daemon.bak file and nothing else AND if you have an undelete utility then try to undelete the daemon.bak file and rename it back to daemon.dll.

29.11.2004, 15:27
well, I used daemon tools to install knights of honor. After that, I restarted the computer, then the error came: c:\windows\daemon.dll is missing. I didn't pay atention to it until I wanted to use daemon tools again. I didn't find it and then I deleted the folder daemon.bak (very stupid) and then I deleted daemon tools with the un-installer. I wanted to install daemon tools again and then it said daemon tools was still on the pc...... And it wasn't on the pc :S. Anyway, I use alcohol 120 % now, but if you have an solution to the problem I will be pleased to here that.

29.11.2004, 15:30
I don't have an undelete utility.. but I still have daemon tools on the pc ( before I reinstalled the computer, daemon tools was still there, so it's not in the list of windows)

29.11.2004, 15:31
Check thread about error 25002 in common problems and solutions forum.

30.11.2004, 19:45
thx everyone for the help!

Greetz Conthre