View Full Version : Daemon tools wont let me open file explorer?

07.08.2016, 20:38
I recently updated to Windows 10 Pro, (automatic, not my choice) and I went to open file
explorer the next time I turned on my laptop but it said "This app can't run on this PC" and
underneath that message said "Daemon Tools doesn't work on this version of winds. Learn

I wasn't even aware I had it on my laptop, since I let my ex use it to play a game for
a day as he stayed at mine. I had no problems but as soon as the laptop updated it
wont let me do anything on the laptop other than go on Chrome. I can't access any files,
and it wont even let me uninstall it :frown:

Windows 10 Pro, version 1607. Samsung laptop. Any help? Really annoyed with the fact I
wasted so much time today trying to uninstall it and had no luck. :dispirited:

09.08.2016, 09:04

DAEMON Tools Pro up to ver. 5.3 or DAEMOn Tools Ultra up to 4.0 doesn't support Windows 10 OS (Windows 10 anniversary update include). To remove DTPro or DTUltra, please go to installation path (C:\Program Files\DAEMON Tools Pro(DTUltra) as default) and remove DTPro\DTUltra entire folder.

29.09.2016, 10:07
Hi Support,

As the op has stated, we can't access file explorer, so to navigate to this directory isn't working.
I have tried starting in safe mode and uninstalling directly from the control panel.
When trying to uninstall I get the same error prompt "This app can't run on this PC".