View Full Version : "Device setup error code 25057 (0x61E1), 2 (0x2)

14.12.2004, 11:30
Operating System: Win XP Servicep 2
Burning Software: Nero
Anti-virus Software: Norton
DAEMON Tools Version: 3.47

I have a problem installing Daemon Tools 3.47.
When installing I either get a message saying "device setup error code 25057 (0x61E1), 2 (0x2)" , or my system reboots with a blue screen saying something about "error st3mp28.sys", wich I have noticed is the name of the SCSI Controller that is used for Daemon Tools.

How can I get D-Tools installed properly? I've tried everything that is mentioned under common problems and so on...

14.12.2004, 11:37
Do you use alternative ntoskrnl.exe (e.g. alternative boot logo)? Please use original OS files only.

14.12.2004, 11:44
No, I'm not using anything like that. Have just installed Win XP from scratch.
I've had one tip about this might be a problem caused by my raid controller, since I'm using a SATA Harddisk. Do you think that might be?

14.12.2004, 11:48
Difficult to say.
Clean or move setupapi.log, remove devices with yellow exclamation marks from device manager, reboot, then try to install. If it fails again check system event log for error messages from Daemon Tools driver, send new setupapi.log and event log message incl. all binary bytes (just copy'n'paste them into mail) to support@daemon-tools.cc with reference to this thread.

15.12.2004, 12:08
I've removed setupapi.log and all devices with yellow marks, and I've tried to install it again.
I got the same message this time.
I'm running a Norwegian OS, so should I still send you a copy of the setupapi.log or is it enough to send you a copy of the Daemon log that is created after installing the program?

15.12.2004, 12:21
Send setupapi.log, maybe you need to translate some stuff. ;)

04.01.2005, 21:40
Hi again.

Just wanted to know if you've had any luck with my problem?
I have resently formatted my harddrive and installed Win XP again, and when I tried to re-install Daemon Tools I got exactly the same Error message as last time.

24.02.2005, 13:51
Operating System: Windows XP Professional SP2
Burning Software: Nero Burning ROM Enterprise Edition (installed later)
Anti-virus Software: Kaspersky Personal 5.0.156 (installed later)
DAEMON Tools Version: 3.47

I just had this problem on fresh Windows XP SP2 installation. Wasn't able to install Kaspersky antivirus too. Visited it's forum and found out that the problem was in the Data Execution Prevention that was introduced in SP2. Solved this problem by turning DEP off in c:\boot.ini by adding key /NoExecute=AlwaysOff. The strange thing is that I used both KAV and Daemon Tools on WinXP SP2 without turning DEP off before without any problem.