View Full Version : Occasional crash on start w/ Safedisc 3.x images

20.12.2004, 16:48
Operating System: Windows XP Pro SP2
Burning Software: Alcohol
Anti-virus Software: NAV2003
DAEMON Tools Version: 3.47


P4 2.4, Intel i865 chipset, 1024mb RAM, Geforce 6800GT, many GB free space, LiteOn LTR-48246S. Intel chipset software is installed, as is SP2, latest microsoft updates. AdAware/SpySpot S&D are clean, no virus infections (NAV2003).

I created some disk images of Doom III and Far Cry. The Far Cry image I made with Blindwrite (v5.xx--can't recall the exact version as this was some time ago). The Doom III image I made with Alcohol

Occasionally (perhaps 20% of the time), when starting either of these games (to play), the system crashes on the splash screen where it checks the copy protection. By this, I mean the mouse freezes, CTRL-ALT-DELETE doesn't work, and the only solution is a reset. The other 80% of the time, the game loads and plays without a problem.

These games are both safedisc 3.x, which is noteworthy. I've made images of lots of securom titles (Civ III Play the world, Unreal Tournament 2004) and these have never once crashed while loading.

This problem is getting really frustrating, as you might imagine, and if nobody here has a solution I think I'll be forced to use a "patch" instead.

Other than this issue, Daemon tools works great. I've used it for standard ISOs a lot of times, and have never had a problem with it. It's just this one issue. :(

Thanks in advance for anything you can suggest. :)

20.12.2004, 17:26
Brief followup: I am not using any emulation in Daemon tools. Perhaps that would be worth a try?

22.12.2004, 15:51
You could try removing the safedisc drivers completely from your system. Then you would need an alternative way to start the game(s), but you would find out wheter the Safedisc protection is the culprit.

23.12.2004, 19:44

Thanks for your reply. The game seems to work normally (without crashing) if I use the original disk. Only when I use the image created with Alcohol do I get the intermittent crashes while the game loads. This indicates (to me) that the safedisc drivers are not the culprit.

However, I would be happy to try what you suggested, but am unsure as to how to proceed. Can you elaborate on how to "remove the safedisc drivers completely" ? How is this done?

Thanks again. :)

16.01.2005, 16:47
Hmm for what it's worth, I've now managed to reproduce this problem using a CD image I created with the latest version of CloneCD (5.0.45 I think) and the game Call of Duty: United Offensive. I started the game twice without issue, then the third time it crashed hard. This seems like it could be a driver issue of some kind.

16.01.2005, 16:49
Do you have CloneCD's Hide CD-R media function and tray enabled or disabled?
Do you have AnyDVD installed? Did you try to disable NAV yet?
And where exactly does it crash? If you start it before the intro, or in the game if you start/load a game?

20.01.2005, 02:24
Thanks for your reply. Answers:

>> Do you have CloneCD's Hide CD-R media function and tray enabled or disabled?
I don't have the CloneCD tray icon running. If I do run it, it defaults to "unchecked". The problem occurred before I installed CloneCD, so I would guess it doesn't have anything to do with the crash. I only installed CloneCD after encountering this problem as an attempt at fixing it.

>> Do you have AnyDVD installed?

>> Did you try to disable NAV yet?
No, I can try that. Have there been issues with NAV in the past, just out of curiousity?

>> And where exactly does it crash? If you start it before the intro, or in the game if you start/load a game?
As stated in the original post, the game crashes at the splash screen, when it's checking the copy protection. To be clear, this is the screen that appears immediately after launching the game, i.e. the _first_ thing that comes up. If the game gets past this initial splash screen, it plays without issue. But 20% of the time, the game does not start--it crashes at this splash screen and the computer becomes unresponsive.

Thanks again for your help, I appreciate it. I'll report back on whether NAV is the culprit.

20.01.2005, 02:33
Hello again,

I just tried disabling NAV2003 by right clicking the system tray icon and selecting "Disable Autoprotect". The game crashed the first time I tried to load it. So it appears NAV is not the culprit :(

FWIW, here's a complete list of all running processes. If you have any questions about any of them--I can supply details. None are spyware.

Image Name PID Session Name Session# Mem Usage
========================= ====== ================ ======== ============
System Idle Process 0 Console 0 16 K
System 4 Console 0 240 K
smss.exe 780 Console 0 372 K
csrss.exe 840 Console 0 2,648 K
winlogon.exe 864 Console 0 3,704 K
services.exe 908 Console 0 5,012 K
lsass.exe 920 Console 0 1,268 K
svchost.exe 1108 Console 0 4,960 K
svchost.exe 1160 Console 0 4,256 K
svchost.exe 1624 Console 0 16,348 K
spoolsv.exe 1848 Console 0 5,588 K
CCEVTMGR.EXE 1908 Console 0 2,656 K
explorer.exe 344 Console 0 16,832 K
daemon.exe 460 Console 0 3,412 K
MBM5.exe 468 Console 0 4,280 K
ccApp.exe 476 Console 0 9,352 K
EM_EXEC.EXE 536 Console 0 3,780 K
firefox.exe 552 Console 0 20,984 K
K9.exe 560 Console 0 9,412 K
Proxomitron.exe 576 Console 0 5,564 K
Qshlfed.exe 688 Console 0 2,644 K
inetinfo.exe 256 Console 0 4,972 K
mdm.exe 264 Console 0 2,512 K
named.exe 292 Console 0 5,472 K
NAVAPSVC.EXE 588 Console 0 792 K
NCS.exe 656 Console 0 3,300 K
NPROTECT.EXE 768 Console 0 6,416 K
nvsvc32.exe 996 Console 0 2,996 K
SymWSC.exe 1576 Console 0 3,288 K
OUTLOOK.EXE 1268 Console 0 6,036 K
WINWORD.EXE 484 Console 0 12,228 K
wuauclt.exe 3884 Console 0 6,740 K
cmd.exe 2896 Console 0 2,508 K
tasklist.exe 3032 Console 0 4,044 K
wmiprvse.exe 3140 Console 0 5,428 K

20.01.2005, 10:48
Probably it's not enough to disable the autoprotection feature, to be sure you've to un-install NAV.

20.01.2005, 23:21
Operating System: Win XP PRO sp2
Burning Software: Nero 6
Anti-virus Software: AVG FREE
DAEMON Tools Version: 3.47

Hi all,
i've same problem :(
when i try to start an iso mounted with safedisc2 profile, os freeze...

my conf :
P4 3.0 fsb800 HT enabled,
1024 mb ram
1 hdd 80 gb sata
1 hdd 180 gb sata
geforce 5900xt

21.01.2005, 01:20
Hmm didn't see the above reply before getting rid of NAV. Anyway, I uninstalled it, and closed essentially everything that was running. Here's an updated process list. The problem still occurred, though it coincidentally took nine tries to reproduce it.

Image Name PID Session Name Session# Mem Usage
========================= ====== ================ ======== ============
System Idle Process 0 Console 0 16 K
System 4 Console 0 240 K
smss.exe 788 Console 0 372 K
csrss.exe 848 Console 0 4,612 K
winlogon.exe 880 Console 0 9,320 K
services.exe 924 Console 0 4,084 K
lsass.exe 936 Console 0 1,352 K
svchost.exe 1128 Console 0 4,988 K
svchost.exe 1176 Console 0 4,308 K
svchost.exe 1596 Console 0 21,652 K
spoolsv.exe 1868 Console 0 6,084 K
explorer.exe 348 Console 0 23,456 K
daemon.exe 464 Console 0 3,364 K
taskmgr.exe 3864 Console 0 4,248 K
svchost.exe 3304 Console 0 4,072 K
cmd.exe 3940 Console 0 2,556 K
tasklist.exe 3748 Console 0 3,992 K
wmiprvse.exe 1644 Console 0 5,440 K

10.02.2005, 19:45
The saga continues... :)

I would post more frequently regarding the status of this issue, but I haven't been playing games much lately, unfortunately. Anyway, after experimenting a bit with the "emulation" feature, I've found that the problem goes away if I enable SafeDisc emulation and use the same CD images. At least, after starting the game about 30 times, it hasn't crashed once, which is far more than in the past. Further, I reinstalled NAV 2003 before enabling emulation, so it's not that or any other app I have running.